Erro - Visual Studio Code (node não executa)

Olá pessoal! Estou a algum tempo quebrando a cabeça aqui, instalei o Visual Studio+node+npm, tudo certinho, porém na hora de executar um comando aparece o seguinte erro: sh: node: command not found

Alguém consegue me ajudar? Agradeço!

@JG22, tá contigo!

Você instalou o node como?
Qual a versão do Mint?
Se você apenas instalou um extensão para o NodeJs, não vai funcionar. Você precisa do SDK…
sudo apt update && sudo apt install nodejs

1 curtida

Instalei via terminal, através deste mesmo comando, o mesmo para o npm… Meu linux é o mint 20.3

Meu node é v12.18
npm v6.14

Executei dnv o código que vc enviou mas segue dando o mesmo erro :confused:
a principio está tudo instalado corretamente, parece que o visual studio n reconhece o node

Testa escrever nodejs ao em vez de apenas node. Caso não funcione, tenta rodar um update geral e reiniciar a máquina. Pode ser que não tenha criado um caminho no bashrc
sudo apt update && sudo apt full-upgrade -y && sudo apt autoremove -y && sudo apt autoclean && flatpak update -y && flatpak uninstall --unused -y
e reinicia.
Se mesmo assim não funcionar, cria um caminho no bashrc.
@Deleterium o caminho do node é /usr/bin/node, como ficaria esse export no bashrc? Só sei fazer se estivesse na própria home…

O /usr/bin já deve estar no PATH por padrão. Ele deve ser inserido quando o bash carrega o /etc/profile, que daí carrega o /etc/profile.env

O que pode ter acontecer é o .bashrc estar errado e sobrescrevendo o PATH.

@realpablosantos Pode mandar o conteúdo do seu ~/.bashrc ?

1 curtida

Seria isso?

# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
case $- in
    *i*) ;;
      *) return;;
esac

# don't put duplicate lines or lines starting with space in the history.
# See bash(1) for more options
HISTCONTROL=ignoreboth

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# If set, the pattern "**" used in a pathname expansion context will
# match all files and zero or more directories and subdirectories.
#shopt -s globstar

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "${debian_chroot:-}" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color|*-256color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
	# We have color support; assume it's compliant with Ecma-48
	# (ISO/IEC-6429). (Lack of such support is extremely rare, and such
	# a case would tend to support setf rather than setaf.)
	color_prompt=yes
    else
	color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\[email protected]\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\[email protected]\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to [email protected]:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\[email protected]\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# colored GCC warnings and errors
#export GCC_COLORS='error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01'

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Add an "alert" alias for long running commands.  Use like so:
#   sleep 10; alert
alias alert='notify-send --urgency=low -i "$([ $? = 0 ] && echo terminal || echo error)" "$(history|tail -n1|sed -e '\''s/^\s*[0-9]\+\s*//;s/[;&|]\s*alert$//'\'')"'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if ! shopt -oq posix; then
  if [ -f /usr/share/bash-completion/bash_completion ]; then
    . /usr/share/bash-completion/bash_completion
  elif [ -f /etc/bash_completion ]; then
    . /etc/bash_completion
  fi
fi

Fiz tudo isso e segue o mesmo problema, realmente acho que é o caminho pode estar errado… Aguardar o Deleterium salvar a pátria, fé!

Esse .bashrc não é executado quando vc abre a sessão no vscode. Estranho porque esse bashrc é específico para algum chroot…

  1. Se vc abrir uma janela do terminal e tentar rodar o node, funciona?
  2. o .bashrc que vc pegou foi o seu usuário mesmo?
  3. Existe um .bash_profile no home do seu usuário?

2

Mandei uma foto para você para ver se ajuda, desculpa a ignorância, sinto que eu estou fazendo algo muito errado kkkk

  1. Da erro também, mas é um erro diferente, não é o erro por não encontrar o comando
  2. Sim, na foto aparece todos que existem, peguei /home/johntitor/.bashrc
  3. Não encontrei

Acho que é problema relacionado ao VSCode.

  1. Feche o terminal no vscode (exit) e abra de novo
  2. Se funcionar, desabilite o relaunch (settings → features → terminal → terminal → integrated → environmentChangesRelaunch).

Não tenho mais ideia do que poderia ser.

Tem um ponto… @realpablosantos você instalou via flatpak ou apt/.deb?

Ainda não resolveu, estou quase desistindo kkkkk. Instalei via flatpak, caso fosse desinstalar e remover tudo, repositório e etc, tem uma forma de fazer isso rápido? Pra tentar instalar via .deb

Você consegue executar o node fora do VSCode? por exemplo, se você abrir um terminal e navegar até a pasta do projeto e rodar dessa forma, funciona? Se não, o problema não é o VSCode.

O que aparece coisa você coloque em um terminal qualquer:

which node

Agora se eu executo por terminal ele funciona… Aparece o seguinte quando digito este comando que vc mencionou /

1

Parece que você instalou o node como root em algum momento por algum método que não o packager do sistema, se você tentar sem ser via usuário root, funciona também?

1 curtida

Você consegue chamar ele via terminal normal?
Cria um console app básico, em downloads e chama ele por lá.
cd Downloads && nano ola.js
Dentro do programa: console.log("Linux não é difícil);
Rode: node ola.js
Se funcionar, instala o VSCode via .deb seguindo os passos a baixo:
flatpak list
Procure pelo vscode
desinstale-o com flatpak uninstal nomeDoProgama
Limpa o “lixo”
flatpak uninstall --unused
Instala via .deb. Download Visual Studio Code - Mac, Linux, Windows
A versão em flatpak NÃO é oficial, apenas as empacotadas como tar.gz, snap, .deb e .rpm… O que acontece: a versão em flatpak tem problemas de permissão para se comunicar com o path do seu sistema ao “subir” o terminal integrado. Sem necessidade alguma de fazer alarde e dar nó em pingo d’água.
image

Funcionou irmão!!! Você é fera, valeu mesmo!! E obrigado a todos que comentaram!!

Só uma coisa que eu acho bom avisar caso você ainda esteja executando seus projetos como root, não é nem seguro nem recomendado.

2 curtidas

@thespation fecha, por favor?

1 curtida