Erro no Libreoffice 6

Pessoal, instalei o libreoffice 6.2.8 (stable), porem não está funcionando, diz que é preciso do link do qt_5.
Executei o comando sudo apt install qt5-default, pois alguns sites sugeriam ele para correção e não funcionou.

erro no terminal
/opt/libreoffice6.2/program/soffice.bin: relocation error: /opt/libreoffice6.2/program/libvclplug_qt5lo.so: symbol _ZN5QIcon9fromThemeERK7QString, version Qt_5 not def
ined in file libQt5Gui.so.5 with link time reference

meu sistema
screenfetch

alguém pode ajudar?

1 Curtida

Estou no SUSE e como nunca tinha visto o erro procurei e achei justamente sobre o suse, lá a solução era upgrade, use o mintupgrade para atualizar pra Linux Mint 19.2.

sudo apt install mintupgrade -y ; sudo mintupgrade check
E depois

sudo mintupgrade download ; sudo mintupgrade install -y

1 Curtida

Não estou com meu pc ligado no momento para experimentar, mas digite no terminal:

apt search libQt5Gui

E veja se aparece algum resultado.
Aí é só instalar com o nome exatamente igual ao do resultado.

1 Curtida

Usa o AppImage que resolve

1 Curtida

Não estou sendo irônico na minha pergunta, mas por quê poderia quebrar?
Por algumas vezes já resolvi problemas desta forma que citei…
Fato que normalmente eu resolvo uma dependência e aparece uma segunda, terceira… Mas vou resolvendo todas e normalmente funciona…

1 Curtida

Se resolve assim ok… sorte sua, abraço…

Desculpe… Mas não tentei ser irônico contigo. De verdade a minha pergunta foi completamente para que eu pudesse aprender mais…
Não foi uma tentativa de confronto com a sua pessoa e sim uma pergunta para que eu pudesse esclarecer a dúvida que a sua colocação me causou…

2 Curtidas

eu executei esse comando e como uso a versão com KDE diz que ão ha atualização para minha distro.

executei o comando e foi sugerido 4 pacotes, instalei todos e continua apresentando o mesmo erro quando tento executar o libreoffice.

Não tenho porque achar que sei mais que alguém aqui, mas usando gerenciadores de pacotes diversos e bem melhores elaborados se posso assim dizer, que o apt, e problemas assim com soluções desse jeito quebram o package manager, pelo menos comigo sempre foi assim, isso quando de fato tem pacotes quebrados, dependências desencontradas e afins. Como esse erro me pareceu ser isso, eu recomendei upgrade e não tentar adicionar o que falta apenas. Isso as vezes é igual até no Windows, tipo, falta dll do visual basic e nego vai e procura apenas a dll ao invés de atualizar os pacotes redistribuíveis VC entende? aí quebra até o Windows esse tipo de solução, pois algum instabilidade causa no mesmo e voltando ao Linux, pode quebrar o gerenciamento de pacotes.

1 Curtida

Então dê purge no libreoffice e reinstala, já que instalou o pacote que o @Miura disse, ao reinstalar pode voltar ao normal.

Entendi! Até mesmo, no caso do Windows que eu entendo melhor do que o Linux, as dlls podem ter sido modificadas quando instaladas em avulso…

Por isso acabei comparando, pois em alguns, alguns* casos é parecido com trocar dll quando necessita do um redistribuível específico…

1 Curtida

Então sugiro que utilize a dica do @anon5368640 e depois faça o que o @Natanael.755 disse, use um AppImage.
Caso não saiba onde encontrar o AppImage, utilize o App Outlet do @messiaslima.

1 Curtida

@Elvys @Miura Interessante aqui, foi que vi que o Mint ainda está em uma versão do Kernel que é ótima, quando chegou no 5 foi o desastre da minha vida -_- com isso a única que consigo usar legal depois de uns 3 anos sem Linux e agora com o PC que tenho foi o (Gecko OpenSUSE) Arch nunca mais, é rolling release, só existe o 5* agora nos repos e compilar num i3 fraco é osso…depois vou testar o Mint…

vou de appimage como sugeriu o @Natanael.755

Obrigado a todos

3 Curtidas