Erro em atualizações do Manjaro

Pessoal, esses dias veio uma das att do Manjaro daquele jeito que eles mandam, uma pá de pacotes por vez. Em geral, dá tudo certo, dessa vez não… (ah, sim, eu uso com Gnome, mas já recebi relatos de erros com Plasma tbm)
Eu sempre faço snapshots antes de cada com o Timeshift, o que me salvou, mas dois erros estranhos ocorreram.

  1. Eu tenho o Todoist em flatpak instalado. Ao atualizar o sistema (sem que o todoist atualizasse), ele quebrou, falta nele o módulo canberra-gtk-module) - nenhum flatpak atualiza desta vez mas ocorre o erro
  2. Eu uso tanto o cliente quanto o plugin do Mega do repo Manjariando - que nunca me deram problemas. Contudo, ao atualizar, o Nautilus parou de abrir pelo usuário; pelo sudo, abre mas com erros (ver abaixo)

Se desinstalo e reinicio, volta ao normal. Mas ao conversar com o responsável pelo Manjariando, ele acredita que houve um erro importante na att dos repos do Manjaro que pode ter afetado os pacotes dele.

Daí eu teria um pedido a quem aqui usar Manjaro com Gnome:

  • Atualizar o sistema, instalar o Todoist por flatpak e ver se há erros na execução (rodando com.todoist.Todoist pelo terminal) - no caso, ele acusar a falta do canberra-gtk-module
  • Instalar o cliente Mega e o plugin para Nautilus, ver se abre no modo “normal” - e tentando abrir pelo terminal. No meu caso, ele fica esperando e acusa o seguinte erro:

Seguem os links para instalar diretamente os pacotes do MEGA e do cliente para Nautilus:

CLIENTE:
http://c3sl.dl.osdn.jp/storage/g/m/ma/manjariando/stable/manjariando/x86_64/megasync-4.3.9.0-1-x86_64.pkg.tar.zst

PLUGIN:
http://c3sl.dl.osdn.jp/storage/g/m/ma/manjariando/stable/manjariando-deps/x86_64/nautilus-megasync-4.3.9.0-1-x86_64.pkg.tar.zst

Agradeço demais a ajuda… óbvio que quem for fazer isso, NÃO DEIXE DE FAZER UM SNAPSHOT com o Timeshift, ok?

1 Curtida

Eu uso Arch, eu precisaria de uma máquina reserva para fazer testes. É uma das minhas intenções no futuro mas, :thinking: se rodar um journalctl -p3 para ver oque ele tenha a nos dizer…

1 Curtida

Bicho, eu dei rollback… acho que isso deve ter sumido, não?

1 Curtida

:thinking: em termos de segurança não deveria sumir, ou deveria ser stored em outro lugar… Vai que é um caso de FBI, CIA, Scotland Yard… Mas acredito que some sim… ele não “espelha” tipo um Wayback Machine… Mas é palpite. Tenho de estudar mais.

O rollback “volta no passado mas o presente dele ainda continua, não deveria rescrever, só mudar de destino” deveria ser a metodologia aqui.

1 Curtida

Rodei aqui, tem coisa pra burro… coloquei num pastebin: #7 0x000055796aaac623 n/a (ele> - Pastebin.com

1 Curtida

Eu consigo ver o código mas parte dele, até o #27. Eu refreshed a página mas ainda só vejo até #27, é isso mesmo?

Ih, o código ficou muito longo mesmo… deixa copiar tudo de novo e colocar num txt, pera ae

Pronto, olha aí: Gofile

:joy: Tem algo errado que não está certo… 1.9kb… Tenta “zipa” o arquivo e eu olho por aqui…

Baixa e abre, uai!

:joy: Ele abre só até o #27… Lembrando eu não tenho Gedit nenhum editor de texto, a não ser o Nano pelo TTY… Eu tentei abrir usando o Google drive e o Firefox direto ///home… Vo tentar o nano.

E nem Libre Office? Ele abre txt!

O meu Arch não está completo, aliás está completo para mim, estes procedimentos uso pouco mas quando preciso tem um trabalho a fazer… Até o Nano só abre aquilo e também está estranho 1.9kb :thinking: deveria ser uns 1mb se é gigante não?

Em txt não, ele é grande mas nem tanto… deixa tentar de novo e mando

Agora vai, são mais de 4000 linhas de log: Gofile
E, mano, instala o Gedit, dps vc tira sabagaça! Hue

1 Curtida

Mania de velho minha, Meu Arch é completamente enxuto, nada foi instalado atoa e nada foi desisntalado… Épocas de Winxp que desinstalar as coisas deixava vestígios, épocas antigas de distros Linux que ficavam orfãos, isso gerava problema para o cpu, ficar caulculando algo que não tem resultado final… Levou umas 7 vezes de formatar e reinstalar o Arch até que eu consegui-se instalar sem precisar desinstalar nada… Mania de Viejo. :joy: Agora sim, +300k de texto :sweat_smile:

1 Curtida

Só para constar eu baixei o arquivo e não entendo nada kkkk
@Rodrigo_Chile nao mais facil fazer backup e reinstalar?

2 Curtidas

A home é separada… mas são 100 programas a reinstalar… e se usar a imagem do Timeshift pra restaurar após a instalação, o problema volta
@RuKsu, achei alguns erros aqui:

feb 19 10:30:38 manjaro gdm[586]: Gdm: Failed to contact accountsservice: Error>
feb 19 10:30:39 manjaro pulseaudio[1510]: Error opening PCM device front:0: No >
feb 19 10:30:39 manjaro pulseaudio[1510]: Error opening PCM device front:2: No >
feb 19 10:30:39 manjaro pulseaudio[1510]: Error opening PCM device front:0: No >
feb 19 10:30:39 manjaro pulseaudio[1510]: Error opening PCM device front:2: No >
– Boot d128ffca9a9b4ab5a7e09a1904e0846c –
feb 19 10:31:23 manjaro kernel: Bluetooth: hci0: don’t support firmware rome 0x>
– Boot 5d7365ff7bd94899bc41bed1c62b7411 –
feb 19 19:37:29 manjaro kernel: Bluetooth: hci0: don’t support firmware rome 0x>
feb 19 19:37:39 manjaro kernel: Bluetooth: hci0: don’t support firmware rome 0x>
feb 19 19:37:49 manjaro gdm-password][1307]: gkr-pam: unable to locate daemon c>
feb 19 19:38:01 manjaro sudo[1763]: pam_unix(sudo:auth): conversation failed
feb 19 19:38:01 manjaro sudo[1763]: pam_unix(sudo:auth): auth could not identif>
feb 19 19:38:01 manjaro sudo[1763]: pam_unix(sudo:auth): auth could not identif>
feb 19 19:39:28 manjaro systemd-coredump[4446]: Process 1747 (baloo_file) of us>

Esses das 10h30 são de antes da att, fiz o snapshot às 10h37 e daí atualizei

1 Curtida

:joy:


O problema me parece ser esta linha “gdm failed to contact accountsservice”

É como se o Nautilus fosse um usuário e ele não está mais nem no grupo sudoers…

Isso é desta linha que eu estou falando… Você ve que ela acontece vários dias… Isso prova que o rollback não afeta o journalctl.
Irei pesquisar isso.

1 Curtida

Olha, pode ser algo importante, eu desinstalei recentemente o Xanmod e isso implicou num erro no Virtual Box, o que deu problemas no grub, mkinitcipio e nos drivers host e guest do VB… será que isso não mexeu nos privilégios do meu usuário?
Lembra da parte dois do tópico de erro no grub?

1 Curtida