Erro de iniciante,erro no Grub do gentoo

Como conserto?

tem que reinstalar o grub

Olá @hackerbuiu1987 seja bem-vindo :wave:

Quando puder, mostre como você estaria criando e configurando a estrutura, a forma que você estaria instalando o Gentoo. Este erro pode ser que o GRUB está instalado onde a estrutura não está corretamente configurada, então o GRUB não sabe oque fazer e te mostra esta tela. É como se o GRUB tivesse lhe perguntando “Onde eu irei, me guia, me oriente, eu estou perdido.” :joy:

:pray:

1 Curtida
1 Curtida

É que o meu computador com gentoo tem o efi-64 em /etc/portage/make.conf ficando assim
GRUB_PLATFORMS=“efi-64” eu faço as partes dos comandos de boot e grub e depois pede o i386-PC então coloco no /etc/portage/make.conf GRUB_PLATFORMS=“i386-PC”

mas só repito o processo do seguinte comando:
Emerge --ask --update --newuse --verbose sys-boot/grub:2

e faço as coisas para reiniciar e dá esse erro no GRUB,acho que teria que fazer tudo de novo,desde o comando:

emerge --ask --verbose sys-boot/grub:2

neh?

1 Curtida

Refazer tudo denovo, é um trampo no Gentoo, pelo menos no Arch que é um pouco “mais fácil” por ser mais “automático”, já da um trabalhinho. No Gentoo deve ser mais trabalhoso ainda. Dito isso o vídeo que o Deleterium passou mostra como colocar o GRUB no caminho certo, tenta seguir o vídeo, se caso não tentou ainda. É bem menas mão de obra seguindo as instruções do vídeo. Caso não de certo então vamos correr atrás de uma solução.

:pray:

1 Curtida