Erro atualização Manjaro

Não consigo atualizar meu sistema e aparece essa mensagem de erro “erro: falha ao efetuar a transação (pacote inválido ou corrompido)
Ocorreram erros e, portanto, nenhum pacote foi atualizado.
Já tentei os comandos abaixo:

sudo pacman-mirrors -f5 
sudo pacman -Syyu
sudo pacman-key --refresh-keys --keyserver pgp.mit.edu
sudo pacman-mirrors -f0
sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Syyu
sudo rm -fr /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Syyu

Clearing the pacman cache might be the way to go. (Limpar o cache do pacman pode ser o caminho a percorrer.)
You could backup of course the content of /var/cache/pacman/pkg before clearing. The following command: (É claro que você pode fazer backup do conteúdo de / var / cache / pacman / pkg antes de limpar. O seguinte comando:)
sudo pacman -Scc
will clear out the whole cache. Then you could run: (limpará todo o cache. Então você pode executar:)
sudo pacman-mirrors -f7 && sudo pacman -Syyu

OU

sudo rm /var/cache/pacman/pkg/*.part
sudo pacman-mirrors -f7 && sudo pacman -Syyu
Fonte: Update Fails - Invalid or Corrupted Package: - Technical Issues and Assistance - Manjaro Linux Forum

1 Curtida

Aparentemente deu certo, estou baixando as atualizações. Obrigado desde já; irei marcar como “solução” assim que terminá-la aqui.