Erro ao tentar atualizar o sistema ou instalar programas (DPKG?)

Liguei o pc e veio uma atualização, mas não tá instalando nem a atualização e nem outro programa.
Isso foi por volta das duas da tarde do dia 29, e eu ia fazer uma postagem aqui logo, mais fui tentar pesquisar e resolver eu mesmo…
…desisto.

PS.: AppImage não tá rodando.

Obrigado pela paciência.


Você disse que tentou resolver o problema por você mesmo antes de reportar ao fórum, você tentou essa solução:

sudo dpkg --configure -a
sudo apt update
sudo apt upgrade

2 Curtidas

$ sudo apt-get install --reinstall libgcrypt20:i386
$ sudo dpkg --configure -a
$ sudo apt-get install -f
$ sudo apt update
$ sudo apt upgrade

2 Curtidas

Esse link me ajudou, pode tentar ele: https://www.vivaolinux.com.br/topico/Duvidas-em-Geral/AJUDA-Nao-foi-possivel-obter-trava

2 Curtidas

já tinha tentado ele, mas da erro no upgrade

dpkg: erro fatal irrecuperável, a abortar:
falta uma nova linha final no ficheiro de lista de ficheiros para o pacote ‘libgcrypt20:i386’
E: Sub-process /usr/bin/dpkg returned an error code (2)

não deu certo não, o erro ao corre o dpkg ainda acontece.

1 Curtida

já que vc vai atualiza a veção do seu sistema porque nao faz backup das coisas e formata logo de uma vez o pc e reinstala tudo do zero . alem de tirar um monte de coisa que vc nao usa mais vc vai ficar com o sistema mais enchuto e com menos probabilidade de ter erros

1 Curtida

Tentou isso?
$ sudo apt-get clean && sudo apt-get update
$ dpkg --configure -a
$ sudo apt-get install -f

2 Curtidas

Não sei se pode ajudar, mas vou postando algumas soluções que achei, qual sua distribuição e a versão?

1 Curtida

É atualização simples, tipo o navegador.
E eu não to conseguindo boota um pendrive, pq não da pra instalar nada e nem executar um appimagem. :disappointed_relieved:

Já tentei sim, e tenteia agora novamente pra ter certeza, mas o erro continua.

Pré-configurando pacotes …
dpkg: erro fatal irrecuperável, a abortar:
falta uma nova linha final no ficheiro de lista de ficheiros para o pacote ‘libgcrypt20:i386’
E: Sub-process /usr/bin/dpkg returned an error code (2)

Linux Mint 19.2 Tina
Cinnamon 4.2.4
Kernel: 4.15.0-66-generic x86_64

Como não teve nem uma solução ate hoje (já se passaram seis dias), eu vou formatar o hd agora.

Obrigado pela ajuda.