Erro ao instalar o Wine no Linux Mint 19.1

#1

sudo apt install --install-recommends winehq-stable
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da “Incoming”.
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
winehq-stable : Depende: wine-stable (= 4.0~cosmic)
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

0 Likes

#2

Eu precisei instalar esses pacotes primeiros.
sudo apt install winehq-staging libavcodec-extra57:i386 --install-recommends

0 Likes

#3

sudo apt install winehq-staging libavcodec-extra57:i386 --install-recommends
Lendo listas de pacotes… Pronto
Construindo árvore de dependências… 50%
Construindo árvore de dependências
Lendo informação de estado… Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da “Incoming”.
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
winehq-staging : Depende: wine-staging (= 4.4~cosmic)
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

0 Likes

#4

Você adicionou o repositório do wine-staging?

0 Likes

#5

Não, como add esse repositório?

0 Likes

#6

Você adicionou algum repositório do wine? (Era essa a pergunta na realidade)

0 Likes

#7

sudo apt-add-repository ‘deb Index of /wine-builds/ubuntu bionic main’
Repositório já existe.

Ubuntu - WineHQ Wiki segui os passos desse site aki

0 Likes

#8

Tenta nessa sequência:

sudo apt install --install-recommends winehq-staging wine-staging wine-staging-i386

0 Likes

#9

Estou tendo problemas também, exatamente nessa parte quando dou o comando para instalar.

sudo apt install --install-recommends winehq-staging wine-staging wine-staging-i386
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
E: Impossível encontrar o pacote winehq-staging
E: Impossível encontrar o pacote wine-staging
E: Impossível encontrar o pacote wine-staging-i386

0 Likes

#10

Você adicionou os repositórios do wine? se não fez segue Ubuntu - WineHQ Wiki

0 Likes

#11

Instalei, tinha dois repositórios, tirei um. Agora instalou não sei como, mais foi.

0 Likes

#12

Eu segui o wiki. veja o que me retorna:

$ sudo apt-add-repository deb https://dl.winehq.org/wine-builds/ubuntu/bionic main
master@gamer-desktop:~$ sudo apt update
Ign:1 http://mirrors.evowise.com/linuxmint/packages tessa InRelease
Atingido:2 http://archive.canonical.com/ubuntu bionic InRelease
Atingido:3 http://mirrors.evowise.com/linuxmint/packages tessa Release
Ign:5 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:6 http://repository.spotify.com stable InRelease
Atingido:7 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic InRelease
Atingido:8 http://dl.google.com/linux/chrome/deb stable Release
Atingido:9 http://ubuntu-archive.locaweb.com.br/ubuntu bionic InRelease
Ign:11 http://repo.vivaldi.com/stable/deb stable InRelease
Atingido:12 https://download.sublimetext.com apt/stable/ InRelease
Obter:13 http://ubuntu-archive.locaweb.com.br/ubuntu bionic-updates InRelease [88,7 kB]
Atingido:14 http://repo.vivaldi.com/stable/deb stable Release
Obter:15 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
Obter:17 http://ubuntu-archive.locaweb.com.br/ubuntu bionic-backports InRelease [74,6 kB]
Obter:18 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [204 B]
Obter:19 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [20,8 kB]
Obter:20 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2.464 B]
Baixados 275 kB em 3s (96,6 kB/s)
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
All packages are up to date.
master@gamer-desktop:~$ sudo apt install --install-recommends winehq-staging
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
E: Impossível encontrar o pacote winehq-staging

0 Likes

#13

você viu que a sudo apt-add-repository ‘deb Index of /wine-builds/ubuntu bionic main’ está entre aspas? porque não está aparecendo quando você roda o comando de update. (Não sei pq o forum ta convertendo a url do repositorio para esse index of)

1 Like

#14

Fiz tudo os passos, foi instalado e cade o wine no linux?

0 Likes

#15

você utiliza pelo terminal se for usar gui tem que instalar uma de terceiros Third Party Applications - WineHQ Wiki. Pensei que estava instalando para usar com o lutris

0 Likes

#16

Quero rodar lol, qual devo instalar?

0 Likes

#17

Lutris mas já aviso de antemão que o LOL não está rodando, em ubuntu, mint e debian.

0 Likes

#18

Ok obrigado mesmo assim

0 Likes

#19

Também não entendi.
Mas já tinha tirado o “Index of” da frente do resto do comando e as aspas também mas não tinha nenhum retorno.

Nesse caso eu resolvi após dar o comando certo e não ter retorno, dei reboot. Após o reboot constou o repositório como disponível, daí dei o comando que wiki indica, porém deu o mesmo erro do amigo @12345. Daí usei o comando que você o indicou e o problema foi resolvido.
Agora estou partindo para a instalação do Lutris.

Muito Obrigado pela ajuda @Robson

1 Like

#20

Ative a arquitetura de 32 Bits no seu dpkg (se o seu sistema for de 64 Bits)
sudo dpkg --add-architecture i386

Baixe e adicione a chave do repositório do Wine
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key

Adicione o repositório para o Mint 19.1
sudo apt-add-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main'

Atualize os repositórios
sudo apt update

Instale os pacotes do Wine (eu vou colocar o Wine Staging, porque ele é o recomendado se você deseja instalar o Lutris para jogar)
sudo apt install --install-recommends wine-staging-i386 wine-staging-amd64 wine-staging winehq-staging

0 Likes

Não consigo instalar o Wine staging (Linux Mint 19.1)