Erro ao instalar novo programas

Bom,ao tenta instalar o programa Astha diretamente do site do mesmo,baixei o arquivo .deb e ao tenta instalar,ele fico processando por mais de 20 minutos no Discover e então eu fechei forcadamente o Discover,mas agora ao tenta instalar um novo programa aparece as seguintes mensagens,e ao tentar dar um update acontece esse Erro,tentei algumas soluções vistas na internet mas todas sem sucesso.

obs: a latter-dock foi um exemplo pra aparecer o problema
obs²:essa tentativa foi da internet

Sistema operacional: Kubuntu 20.04
Versão do KDE Plasma: 5.18.4
Versão do KDE Frameworks: 5.68.0
Versão da Qt: 5.12.8
Versão do kernel: 5.4.0-31-generic
Tipo de sistema operacional: 64 bits
Processadores: 2 × Pentium® Dual-Core CPU E5500 @ 2.80GHz
Memória: 3,8 GiB de RAM

Por algum motivo a chave desse repositório foi deletada (ou corrompida, alterada, …).
Para adicioná-la novamente use o comando:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5

Fonte: apt - How to fix GPG in updater - Ask Ubuntu

Deu certo essa,mas agora pede outra e continua nao fazendo update…

arsm@arsm:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
[sudo] senha para arsm:
Executing: /tmp/apt-key-gpghome.bIex7nMSmi/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 40976EAF437D05B5
gpg: chave 40976EAF437D05B5: chave pública “Ubuntu Archive Automatic Signing Key ftpmaster@ubuntu.com” importada
gpg: Número total processado: 1
gpg: importados: 1
arsm@arsm:~$ sudo apt update
Atingido:1 http://br.archive.ubuntu.com/ubuntu focal InRelease
Atingido:2 https://dl.winehq.org/wine-builds/ubuntu focal InRelease
Obter:3 http://br.archive.ubuntu.com/ubuntu focal-updates InRelease [107 kB]
Obter:4 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Atingido:5 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:6 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu focal InRelease
Obter:7 http://br.archive.ubuntu.com/ubuntu focal-backports InRelease [98,3 kB]
Ign:8 http://archive.canonical.com precise InRelease
Atingido:9 Index of /232905/apt/ubuntu focal InRelease
Obter:10 http://br.archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [90,5 kB]
Obter:11 http://archive.canonical.com precise Release [8.180 B]
Obter:12 http://br.archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [136 kB]
Obter:13 http://archive.canonical.com precise Release.gpg [181 B]
Obter:14 http://br.archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [532 B]
Ign:13 http://archive.canonical.com precise Release.gpg
Obter:15 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [16,6 kB]
Obter:16 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [208 B]
Lendo listas de pacotes… Pronto
W: Erro GPG: http://archive.canonical.com precise Release: As seguintes assinaturas eram inválidas: 630239CC130E1A7FD81A27B140976EAF437D05B5
E: The repository ‘http://archive.canonical.com precise Release’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Nossa, agora que eu percebi que você adicionou os repositórios para o “precise” (Ubuntu 12.04). Esses repositórios são muito antigos e não são mais suportados há anos (O suporte do 12.04 acabou em 2017). Remova esses repositórios, usando o aplicativo “Gerenciador de Aplicativos” (eu acho, não tenho o KDE para testar, mas é algo do gênero) e depois tente novamente. Remova todos que tenham referência ao “precise”.

Também é possível fazer pelo terminal, mas ai vai ser necessário que você saiba usar o Nano ou Vi/Vim:
sudo apt edit-sources

1 Curtida

Obrigado acredito que a parte do update resolveu.

sudo apt-get update
Atingido:1 Index of /232905/apt/ubuntu focal InRelease
Atingido:2 http://br.archive.ubuntu.com/ubuntu focal InRelease
Atingido:3 http://dl.google.com/linux/chrome/deb stable InRelease
Atingido:4 http://br.archive.ubuntu.com/ubuntu focal-updates InRelease
Atingido:5 http://br.archive.ubuntu.com/ubuntu focal-backports InRelease
Atingido:6 https://dl.winehq.org/wine-builds/ubuntu focal InRelease
Obter:7 http://security.ubuntu.com/ubuntu focal-security InRelease [107 kB]
Atingido:8 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu focal InRelease
Baixados 107 kB em 1s (89,4 kB/s)
Lendo listas de pacotes… Pronto

Só ainda continua dando esse problema do Astha

sudo apt-get upgrade
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
E: O pacote astah-professional precisa ser reinstalado, mas não foi possível encontrar um arquivo para o mesmo.

Aonde vai pra remover isso.

1 Curtida

Esse pacote está quebrado e pelo jeito foi baixado dos repositórios removidos, e agora não existe mais para ser reinstalador. O jeito é removê-lo e instalar de outra forma. Pelo o que eu vi, no site do programa é disponibilizado um .deb que pode ser usado para instalar.
Então, para remover o programa:
sudo apt purge astah-professional
sudo apt autoremove
sudo apt autoclean

Depois, baixe o .deb no site e instale-o (abrir o arquivo deve abrir o instalador de pacotes automaticamente):

Obs.: Se não abrir automaticamente o instalador de pacotes, use o comando para instalar manualmente (substitua o <pacote.deb> pelo caminho/nome do arquivo baixado):
sudo dpkg -i <pacote.deb>


Adendo:
Na página de suporte deles também é recomendado usar o “.deb” (na seção Using Deb Package):

1 Curtida

Deu certo por aqui, Muito Obrigado pela ajuda.

mas so funcionou apos baixar e executar o .deb do site com o comando sudo dpkg -i,iniciar a instalação dele e só apos remover.
depois disso deu tudo certo o apt-get upgrade funcionou e tudo volto ao normal :grinning: :grinning:

1 Curtida