Erro ao instalar Iriun Webcam

Oi pessoal, sou novo com linux e tive o meu primeiro problema quando tentei instalar o programa Iriun Webcam no Ubuntu 20.04


Se conseguirem me ajudar agradeço demais!!

cara vamos lá…

não uso o ubuntu…
mas vamos ver pelo erro

na imagem enviada fala de um erro no v4l2loopback

primeiro tente instalar o v4l2loopback
sudo apt install v4l2loopback-dkms

depois tente novamente instalar o pacote Iriun

Olá! Eu fiz esse procedimento que você indicou, porém não instala nada.

Tentei instalar o Iriun Webcam pelo pacote .deb do site e aparece a mensagem de “erro” na instalação do pacote.

E a mensagem de erro é esta:

Selecting previously unselected package iriunwebcam.
(Reading database …
(Reading database … 5%%
(Reading database … 10%%
(Reading database … 15%%
(Reading database … 20%%
(Reading database … 25%%
(Reading database … 30%%
(Reading database … 35%%
(Reading database … 40%%
(Reading database … 45%%
(Reading database … 50%%
(Reading database … 55%%
(Reading database … 60%%
(Reading database … 65%%
(Reading database … 70%%
(Reading database … 75%%
(Reading database … 80%%
(Reading database … 85%%
(Reading database … 90%%
(Reading database … 95%%
(Reading database … 100%%
(Reading database … 607222 files and directories currently installed.)
Preparing to unpack …/Documentos/iriunwebcam.deb …
Unpacking iriunwebcam (2.2) …
Setting up iriunwebcam (2.2) …
modprobe: ERROR: could not insert ‘v4l2loopback’: Bad address
dpkg: error processing package iriunwebcam (–install):
installed iriunwebcam package post-installation script subprocess returned error exit status 1
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) …
Processing triggers for desktop-file-utils (0.23+linuxmint8) …
Processing triggers for mime-support (3.60ubuntu1) …

Agradeço desde já a ajuda!

O erro parece que vc está tentando instalar como usuário normal…

Tem que instalar com permissão root…

Tente ser linha de comando…

Antes de instalar, tente subir o módulo…

sudo modprobe v4l2loopback

Não instala nada, infelizmente.

é do arch

veja se ajuda

https://wiki.archlinux.org/index.php/Webcam_setup

Pode parecer bobo, mas já tentou reiniciar? Alguns módulos podem requerer um reboot pra funcionar de forma adequada.

1 Curtida

Tenta assim Jacqueline, sudo apt install e o pacote que vc ta tentando instalar, talvez vá.

Não seria melhor usar o droidcam? ja que a instalação e bem mais funcional com menos dor de cabeça

Ok

Crie um arquivo
/etc/modules-load.d/webcam.conf

Uso o seu editor preferido
Aqui vou dar como exemplo o gedit

sudo gedit /etc/modules-load.d/webcam.conf

E adicione

v4l2

Salve e reinicie
Tente instalar novamente

Sim, @Dio, eu reiniciei durante a madrugada, atualizei o sistema e hoje à tarde tentei novamente os mesmos procedimentos e não dá certo.

@CanalOCaraDoTI, eu atualizei os pacote com sudo apt-get update , tentei novamente e mesmo assim não dá certo.
cmd3

Agradeço a atenção e disponibilidade de todos em ajudar, mas vou deixar isso de lado, pois está dando muito trabalho para mim e para vocês que estão dispondo do seu tempo para ajudar.

1 Curtida

Ok…

Se quiser tente a configuração que falei…

E teste sua webcam…

Magina estamos aqui pra ajudar hehe vou ate tentar no Ubuntu MATE aqui e vÊ se vai !!!

1 Curtida

Galera estou tendo o mesmo problema no zorinos, que é baseado no ubuntu, já tentei tudo mencionado acima, mas não dá

Então pessoal…
@androwin_tutoriais @JKSS @fernands

Agora vendo sobre o problema específico

modprobe: ERROR: could not insert 'v4l2loopback': Operation not permitted

Parece ser um problema com security boot
Fonte do próprio pacote v4l2loopback: Unsigned v4l2loopback module leads to error · Issue #306 · umlaeute/v4l2loopback · GitHub

  1. Desinstalar v4l2loopback com: sudo apt-get remove --auto-remove v4l2loopback-dkms
  2. Instalar v4l2loopback novamente com: sudo apt-get install v4l2loopback-dkms

Você receberá uma mensagem sobre ‘Configuring Secure Boot’, que oferece a oportunidade de criar uma chave para este módulo. Leia com atenção e continue com as abas e pressione enter. Após definir a chave/senha e reinicializar com a chave/senha:

  1. Comando no terminal: sudo modprobe v4l2loopback
  2. Instale o arquivo deb Iriun Webcam novamente

até pessoal
:+1:t2:

1 Curtida

Vi sua mensagem e resolvi testar novamente, porém não funcionou.

Desinstalei mais de 2gb do sistema com esse comando (aliás nem sei pra que serve esse módulo problemático que só dá dor de cabeça rsrs), até ai, tudo bem.

cmd1

Instalei novamente o módulo com o comando sugerido e sem problemas até aqui.

cmd2

Reinicializei o notebook e tentei usar o comando sugerido e, a partir daí, não deu certo. Tentei instalar o pacote .deb do Iriun novamente, mas o mesmo erro continua. Isso é tão desmotivador, principalmente para mim que não entendo de programação nem de arquitetura de sistemas, pois me impossibilita de tentar alguma coisa ou de ao menos de especular o que seria o problema/solução :cry:

cmd3

PS: Para mim não apareceu em nenhum momento esta mensagem

Então para mim também não, mas eu ja estou usando o droid cam agora, mas ainda estou tentando, pois já usava o iriun a algum tempo no windows, então queria usar no linux por já estar familiarizado, e meu secure boot já esta desabilito na bios, eu desabilitei na hora de instalar o zorin, pois tive que alterar o modo de boot e colocar CSM e UEFI

Eu fiz o que vc disse só que dessa vez com o secure boot, fica no mesmo erro, fiz tudo certinho, mas o erro permanece, não sei o que fazer

Ok…

Esta foi a solução encontrada no site do pacote para a instalação no Ubuntu…

Tente remover o pacote v4l2loopback-dkms, reinicie o pc e instale novamente…
Veja se assim funciona…
Como é pacote relacionado ao kernel, pode ser que tenha de reiniciar.

O secure boot não é algo configurado lá na BIOS?