Erro ao compilar codigo - Netbeans 12.0

Olá Pessoal, Tudo bem?

Gostaria da ajuda de vocês. Estou migrando de sistema operacional, uso o windows para algumas questões no trabalho, porém estou migrando para o Pop’os, que inclusive estou gostando muito.

Estou aprendendo programação e baixei o Netbeans 12.0, instalei normalmente, porém ao compilar com código, ele apresenta uma erro: unable to find package java.lang in classpath or bootclasspatch.

Gostaria de saber se conseguem me ajudar com essa questão.

Agradeço a todos!

1 Curtida

Pessoal, consegui resolver.
No meu caso o erro era por conta da JDK, pois não estava direcionada corretamente.

Resolução: Baixei a JDK 14 (Compatível com o meu Netbeans 12.0), em seguida, no meu projeto, cliquei com o Botão direito, Propriedades>Bibliotecas. Em java Platform, cliquei em Manage Platforms e direcionei a JDK correta.

Após ter realizado este processo, o código compilou normalmente.

Fica a dica ai pra quem tiver problemas, assim como eu tive.

Abraços!

3 Curtidas