Erro ao abrir Ondsel (Programa CAD)

Olá, estou querendo usar o programa OndSel um programa baseado no freecad, onde ele é mais moderno que o Freecad o problema é que ele não abre, parece ser um problema de drivers
O erro geral é o seguinte

WebEngineContext used before QtWebEngine::initialize() or OpenGL context creation failed.
QGLXContext: Failed to create dummy context
Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples 0, swapBehavior QSurfaceFormat::DefaultSwapBehavior, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile)

Antes dessa mensagem há um erro de carregar drivers, deixei separado, pois tenho 2 placas de video no notebook, a da CPU, intel grafics 4400, e a dedicada, Radeon 8670M, a qual uso o drive AMDGPU em vez do antigo Radeon,

Quando executo sem comando, o qua usa a intel, ele gera

failed to load driver: crocus

Quando coloco DRI_PRIME=1 pra rodar via AMD, gera

failed to load driver: radeonsi

Em ambos também dá o erro

failed to load driver: swrast

Configs do meu Pc:

 System:
  Kernel: 6.8.0-76060800daily20240311-generic x86_64 bits: 64
    Desktop: GNOME 42.5 Distro: Pop!_OS 22.04 LTS
Machine:
  Type: Portable System: Dell product: Inspiron 5537 v: A12
    serial: <superuser required>
  Mobo: Dell model: 0YK7DY v: A00 serial: <superuser required> UEFI: Dell v: A12 date: 05/27/2019
Battery:  ID-1: BAT1 charge: 7.3 Wh (100.0%) condition: 7.3/66.6 Wh (11.0%)
CPU:  Info: dual core model: Intel Core i7-4500U bits: 64 type: MT MCP cache:
    L2: 512 KiB
  Speed (MHz): avg: 1798 min/max: 800/3000 cores: 1: 1804 2: 1796 3: 1796
    4: 1796
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
  Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 M430 Radeon
    520 Mobile]
    driver: amdgpu v: kernel
  Display: wayland server: X.Org v: 1.22.1.1 with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: amdgpu,ati,modesetting
    unloaded: fbdev,radeon,vesa gpu: i915 resolution: 1360x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4400 (HSW GT2)
    v: 4.6 Mesa 24.0.0-1pop0~1706872735~22.04~0fa430c
Audio:
  Device-1: Intel Haswell-ULT HD Audio driver: snd_hda_intel
  Device-2: Intel 8 Series HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k6.8.0-76060800daily20240311-generic running: yes
  Sound Server-2: PipeWire v: 1.0.3 running: yes

Como o programa é empacotado? O Ubuntu/PopOS 22.04 é a distro para qual ele é recomendado?

Não tenho muito como responder de maneira concreta pois o site pede registro para baixar.

Na AppImage do FreeCAD tem um problema parecido e o link sugere uma solução com LD_PRELOAD.

Acabei “”“Resolvendo”“”" o problema

Não sei se foi nesta issue que eu acabei chegando também, já que ele é baseado no FreeCAD, creio que foi outra e parecia ser um erro de dependência as quais no meu pc estavam atualizadas, não quis tentar fazer o downgrade para não quebrar outras coisas no sistema, bem eu “Resolvi” baixando um Pre-Release para testes a qual funcionou, mas as vezes fecha sozinho :\

Mas respondendo as outras questões

ele é um AppImage

Não tem recomendação, a tela de download:
image

Obrigado pela atenção :slight_smile:

1 curtida

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.