Erro adicionar PPA

sudo add-apt-repository ppa:ubuntu-desktop/ppa
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 95, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 103, in __init__
    self.sourceslist = SourcesList()
  File "/usr/lib/python3/dist-packages/aptsources/sourceslist.py", line 273, in __init__
    self.matcher = SourceEntryMatcher(matcherPath)
  File "/usr/lib/python3/dist-packages/aptsources/sourceslist.py", line 474, in __init__
    dist = DistInfo(f, base_dir=matcherPath)
  File "/usr/lib/python3/dist-packages/aptsources/distinfo.py", line 338, in __init__
    template.description = _(value)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe7 in position 8: invalid continuation byte

Ol√° @Luis_Lafer tudo bem contigo?

Descreva o problema e informe em qual distro/versão e qual era o PPA que você pretendia ativar. Somente com estas linhas de erro fica difícil te dar uma resposta objetiva.

:vulcan_salute:

1 curtida

Opa…desculpa…
Estou tentando jah faz 2 dias instalar um print server no rapberry pi com uma impressora Canon Prixma MP210 e nao consigo… Instalei o CUPS mas ele nao tem, driver para esta Canon…
Toda a vez que tento adicionar qq PPA dar este erro…

" sudo add-apt-repository ppa:michael-gruz/canon-trunk"

Qual é a versão do Linux que você instalou neste Pi?

:vulcan_salute:

Boas…
aqui esta a versao…
Obrigado :slight_smile:

PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION_ID="11"
VERSION="11 (bullseye)"
VERSION_CODENAME=bullseye
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

Boa tarde. Amigo no Debian n√£o se instala ppa. Da muito problema.

Ok…então como faço ?

Você precisa pesquisar por drivers que sejam compatíveis com o Debian, encontrei este abaixo, mas só testando para ter certeza se vai te ajudar ou não.

:vulcan_salute:

Aproveite e mande uma reclamação pra Canon dizendo-se ser um cliente insatisfeito por não haver drivers pro Linux.

1 curtida

Obrigado…
Por acaso alguem jah instalou esta impressora no raspiberry como servidor de impressao ???

Por acaso não sei o que aconteceu…consegui ontem imprimir uma folha de teste… O problema é que não sei o que instalei que funcionou …
Agora só está faltando imprimir pelo celular e um server scanner… Espero que funcione…:blush::disappointed_relieved::sweat::smiley::slightly_smiling_face::pray::pray::pray:

Boas…
Achei o que talvez tenha me resolvendo o problema… instalei o " Gutenprint" …
Acredito que tenha sido este programa que tenha instalado os drivers da impressora Canon …
Obrigado a todos que me ajudaram…

Ainda dá para desejar um Feliz Natal e um Próspero Ano Novo … :slight_smile:

2 curtidas