[Dúvida] GDebi não instala por falta de dependências ou algum problema de configuração?

Opa, olá o/

Não tem muito tempo que comecei a usar Linux (quase 4 meses), e já passei por sistemas como Linux Mint e Zorin OS. Eu ainda fui ousado e fiquei usando o Arch Linux já faz 2 meses (e tive uma experiência muito boa para um iniciante), mas eu acabei me apegando um pouco a distribuições Debian/Ubuntu-based. Assim eu decidi testar o Debian 10 para saber se ele me atende bem, mas ainda estou me adaptando e aprendendo sobre.

Sei que o Debian tem como característica reter updates de pacotes, e por isso tem uma ótima estabilidade. Após eu terminar os processo de instalação e pós-instalação eu tentei instalar o Discord via .deb (usando o GDebi). O problema é que eu cliquei em Instalar, e mesmo assim não aconteceu nada

Então fiz o processo via terminal e aconteceu isso

Não achei nada que me fez compreender isso, por isso vim perguntar por aqui. Desculpe se isso for meio bobo, mas, como eu disse, eu ainda estou testando e me adaptando com ele.

Consegue por flatpak? Pq facilita a vida…

Ainda não instalei o Flatpak, nem Snap, mas eu só queria saber antes de fazer qualquer coisa. Pois como ainda estou me acostumando isso pode acontecer novamente e não sei o que fazer caso não tenha versão Flatpak e Snap

1 Curtida

Tem duas opções, ao que me parece: instalar as dependências (não lembro bem como faz pra puxar as deps ao dar o sudo apt install, espera o povo aqui ajudar); ou instalar o suporte a flatpaks, pq o Discord está lá sim

Esse é um bug já conhecido no GDebi do Debian mas que devido à política de manter o parque dos dinossauros do Debian, ainda não atualizaram. Mas é só aviso, pode dar Y sem medo.

Se não estiver conseguindo usar o Gdebi por causa disso, sempre tem a opção de ir direto pelo APT:

sudo apt install ~/Downloads/discord-0.0.12.deb

3 Curtidas

Sim, eu não estava conseguindo utilizar. Não sabia dessa parte do APT, só do comando do GDebi mesmo…

mas funcionou, obrigado pela dica :slight_smile:

3 Curtidas