Duvida-Erro de diretorio manjaro KDE

Boa noite quando tento abrir o menu de adicionar ou remover programa da este erro >> Não foi possível tornar o serviço Adicionar/remover programas executável, cancelando a execução.
No such file or directory. isso aconteceu depois que atualizei pelo terminal.

Esse adicionar e remover programas é o Pamac, e recentemente ouvi sobre umas tretas dele no Manjaro. Vou chamar o quebra-galho, @Rodrigo_Chile! Dá um help pro amigo aqui

1 Curtida

Hahahahaha… eu tinha visto
Vamos lá, primeiro tentar reinstalar o bicho, sudo pacman -Ss pamac pra ver o nome certinho

2 Curtidas

No meu caso, como está tudo ok, ele vem com a seguinte resposta:

extra/pamac-cli 10.0.3-1 [instalado]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-common 10.0.3-1 [instalado]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-flatpak-plugin 10.0.3-1 [instalado]
Flatpak plugin for Pamac
extra/pamac-gnome-integration 10.0.3-1 [instalado]
Pamac gnome integration
extra/pamac-gtk 10.0.3-1 [instalado]
A Package Manager based on libalpm with AUR and Appstream support
extra/pamac-qt 0.3.2-2
A Qt5 frontend for libalpm - prerelease version
extra/pamac-snap-plugin 10.0.3-1 [instalado]
Snap plugin for Pamac
extra/pamac-tray-icon-plasma 0.1.2-2
Pamac tray icon for plasma users

1 Curtida

Se o pamac-gtk (ou -qt, eu não sei ao certo qual deles o Manjaro usa, imagino que seja o -qt) aparecer como não instalado, aí é:
sudo pacman -Syu pamac-qt (ou -gtk)

Se aparecer instalado, pode ter se corrompido, aí é
sudo pacman -Syu pamac-gtk --overwrite

E conta o que rolou pra gente

1 Curtida

Ok amigos, agora estou no trabalho amanhã assim que eu chegar em casa vou tentar e aviso pra vocês o resultado , muito obrigado a todos e uma ótima noite!

2 Curtidas

Boa tarde, e tentei instalar o gtk mas deu esse erro >>sudo pacman -Syu pamac-gtk – overwrit
:: Sincronizando a base de dados de pacotes…
core está atualizado
extra está atualizado
community está atualizado
multilib está atualizado
atenção: pamac-gtk-10.0.3-1 está atualizado – reinstalando
erro: alvo não encontrado: overwrit

E alguns programas sumiram do menu, e não, ta aparecendo adicionar ou remover programa.

faltou um “e” em overwrite

sudo pacman -Syu pamac-gtk – overwrite
:: Sincronizando a base de dados de pacotes…
core está atualizado
extra está atualizado
community está atualizado
multilib está atualizado
atenção: pamac-gtk-10.0.3-1 está atualizado – reinstalando
erro: alvo não encontrado: overwrite

mesmo assim não deu :frowning:

Já vejo isso, mas se der pacman -h aparece como dar o comando de overwrite

E pra variar estou tentando instalar o yaourt pra instalar o chrome ta dando erro tambem >>sudo pacman -Sy yaourt
:: Sincronizando a base de dados de pacotes…
erro: falha ao atualizar core (não foi possível travar a base de dados)
erro: falha ao atualizar extra (não foi possível travar a base de dados)
erro: falha ao atualizar community (não foi possível travar a base de dados)
erro: falha ao atualizar multilib (não foi possível travar a base de dados)
erro: falha ao atualizar archlinuxfr (não foi possível travar a base de dados)
erro: falha ao sincronizar todos as bases de dados

desculpe tomar seu tempo é a primeira vez que estou usando manjaro!

não é -- overtwrite é --overwrite
a palhavra tem que estar grudada nos hífens pro pacman entender
sudo pacman -Syu --overwrite pamac-gtk pamac-qt

1 Curtida

E o Manjaro não usa yaourt, só o yay, mas que se torna meio inútil ao habilitar o AUR no pamac, pq aí basta mandar pamac build pacote

sudo pacman -Syu --overwrite pamac-gtk pamac-qt
:: Sincronizando a base de dados de pacotes…
core está atualizado
extra está atualizado
community está atualizado
multilib está atualizado
archlinuxfr está atualizado
:: Iniciando atualização completa do sistema…
resolvendo dependências…
atenção: não é possível resolver “pamac-common<9.6.0”, uma dependência de “pamac-qt”
:: O seguinte pacote não pode ser atualizado devido a dependências não resolvidas:
pamac-qt

:: Deseja ignorar o pacote acima para esta atualização? [s/N]

o pamac-qt quer uma versão do pamac que ainda não tá nos repositórios, aparentemente, vc vai ter que esperar uma atualização por parte da comunidade do manjaro

vc precisava acessar o adicionar e remover programas para o que? queria instalar um programa? remover um programa? qual programa?

É pra instalar o chrome pelo AUR mas ja consegui! muito obrigado

1 Curtida

Gostaria de agradecer a todos consegui resolver o problema e desculpem os vacilos sou iniciante e nunca tinha instalado o manjaro! BOAS FESTAS A TODOS E UM FELIZ ANO NOVO vocês são fera um dia chego lá.

1 Curtida

Galera só mais uma duvida, como faço pra instalar o google chrome pelo terminal?
pois tentei pelo AUR e deu falha!

Não instala o Chrome que é roubada. Dá pra fazer tudo o que o Chrome faz usando o Chromium e ele está no repositório do Manjaro

É vou desistir do manjado e continuar com o fedora mesmo, agora precisei reiniciar o Pc entrou no grub normal selecionei o manjado aí começou a iniciar mas só fica na tela pra e não aparece nada já tem uns 10 minutos. Valeu galera