Dúvida com pacote Harfbuzz

Olá,
Recentemente realizei a atualização do Fedora para a versão 31. Após a atualização um software que eu utilizava em cima do electron (bibisco versão 2.0.3) não está rodando e estou tento o seguinte retorno:

(bibisco:64086): Pango-ERROR **: 08:57:52.537: Harfbuzz version too old (1.3.1)

Trace/breakpoint trap (imagem do núcleo gravada

Porém a versão instalada do pkg está bem atualizada e longe da informada pelo erro, estando na versão 2.6 do Harfbuzz
.

Alguém já teve ou sabe o que fazer para solucionar esse problema ?

Grato a todos que responderem

Esse programa está usando uma versão antiga do Electron em que os desenvolvedores cometeram um deslize: embutiram a Harfbuzz mas não o Pango. Aí o Pango do seu sistema foi chamado para o combate mas a versão do Harfbuzz embutida no aplicativo é velha.

Tem duas soluções aqui. A ideal seria aguardar uma atualização. Se não for uma opção, tem uma gambiarra - compilar o Pango antigo no seu PC e mandar o programa usar ele. Mas aí se precisaria saber qual versão do Fedora ele rodava certinho pra baixar o .src.rpm apropriado.

1 Curtida

Capezotte vlw pela dica, compilando o pango e setando o app para utilizar essa versão funcionou certinho :grinning: