[Dúvida] Arch Linux Instalação

Códigos

loadkeys pt-latin1
wifi-menu (ligação por wireless)
timedatectl set-ntp true
timedatectl set-localtime Europe/Lisbon

cfdisk - Partição DOS (MRB)
mkfs.ext4 /dev/sda1
mkfs.ext4 /dev/sda2
mkswap /dev/sda3

mount /dev/sda1 /mnt
mkdir /mnt/home
mount /dev/sda2 /mnt/home
swapon /dev/sda3

nano /etc/pacman.d/mirrorlist
pacstrap /mnt base

genfstab -U /mnt >> /mnt/etc/fstab
cat /mnt/etc/fstab

arch-chroot /mnt
ln -sf /usr/share/zoneinfo/Europe/Lisbon /etc/localtime
hwclock --systohc

nano /etc/locale.gen
locale-gen
echo LANG=en_GB.UTF-8 >> /etc/locale.conf
echo KEYMAP=pt-latin1 >> /etc/vconsole.conf
echo arcade >> /etc/hostname
nano /etc/hosts
127.0.0.1 localhost
::1 localhost
127.0.1.1 arcade.localdomain arcade

passwd
systemctl enable dhcpcd
useradd -m bruno
passwd bruno

pacman -S sudo
nano /etc/sudoers
usermod -aG wheel.audio.video.optical.storage bruno

pacman -S grub
grub-install /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg

pacman -S dosfstools os-prober mtools network-manager-applet networkmanager wpa_applicant wireless_tools dialog

ctrl + D
reboot

Tentei pela primeira vez instalar o Arch Linux, contudo não tem sido tarefa fácil, com a ajuda da Arch Wiki, Diolinux e Distrotube finalmente consegui instalar o Arch via Wireless.

Instalei os pacotes para executar o wifi-menu depois do reboot, mas ele da erro Job for nctl…

Como posso conseguir por o wireless a funcionar?? ou usar cabo de rede?

O nome correto do pacote é “wpa_supplicant”. Tem certeza que instalou corretamente?

Mais uma coisa… Como tu instalou o “os-prober” imagino que tu tenha Dual Boot, os outros sistemas apareceram no Grub?

E mais uma pergunta. Tu executou os comandos durante a instalação exatamente na mesma ordem em que eles estão aqui no teu post?

por essa exata ordem, eu não consigo ligar mesmo que tenha outra encryptação, eu não tenho instalado no sistema outro os por isso não consigo disser.

Eu utilizei o código do video do dio para instalar os pacotes, e não deu qualquer erro… no entanto terei de usar o usb e entrar no chroot para verificar?

useradd -m -g users -G wheel bruno

pacman -S sudo
nano /etc/sudoers
Opção 1–> descomenta %wheel ALL=(ALL) ALL
Opção 2 --> acrescenta bruno ALL=(ALL) ALL

Txt simplificado:


OBS1: ignora a parte do yaourt
OBS2: o Display Manager, lightdm é uma boa escolha para DE que não possui DM como XFCE, se vc for usar por exemplo o gnome, melhor usar a padrão dele que é a gddm.

Driver de Video

Nvidia: pacman -S nvidia nvidia-settings nvidia-utils lib32-nvidia-utils

Intel: pacman -S xf86-video-intel libgl mesa

Amd: pacman -S mesa xf86-video-amdgpu

Virtualbox: virtualbox-guest-utils virtualbox-guest-modules-arch mesa mesa-libgl

Como instalar as DE e varias dicas:

OBS3: Senão tiver outro sistema não tem necessidade de instalar o pacote os-probe.

Distrotube é o cara. :grinning:

1 Curtida

Sim, vai ter que dar boot pela mídia de instalação, montar a partição do sistema e entrar como “chroot”.

Após estar em “chroot” conecta com a internet e instala o pacote correto, como falei no meu comentário anterior.

pacman -S wpa_supplicant

Os comandos que eu sempre usei para adicionar usuárioe hostname são os seguintes:

echo nomedamáquina > /etc/hostname

passwd

useradd -m -g users -G wheel -s /bin/bash nomedousuário

passwd nomedousuário

Assim sempre funcionou pra mim.

APENAS se por acaso o Grub não aparecer ao reiniciar, recomendo voltar como “chroot”, desinstalar o “os-prober”, rodar o “grub-mkconfig” e reiniciar. Se precisar do “os-prober” instale-o e rode o “mkconfig” novamente após ter dado boot pelo HD, e não em “chroot”.

grub-mkconfig -o /boot/grub/grub.cfg

1 Curtida

Infelizmente está na mesma…

Consegui ao pesquisar e digitar,
ip link set down wlp4s0, depois corri o wifi menu e dei ping.

Essa é a saída do comando “wifi-menu”?

Sei que parece uma pergunta besta, mas, tem 100% de certeza de que os pacotes “dialog, wireless_tools e wpa_supplicant” estão instalados?

Não tenho o Arch instalado no momento pra testar, mas acho que o comando…

pacman -Qi nomedopacote

…vai te informar se o pacote está instalado ou não. Tenta checar.

Se não der certo tenta fazer o seguinte:

Volta como “chroot”, instala uma interface gráfica, um gerenciador de login e o Network Manager, ativa esse gerenciador de login e inicia o sistema com interface gráfica. Daí então conecta ao wifi com o Network Manager.

Tenho a certeza porque fiz outra vez a instalação.

Bom, como eu disse, minha única ideia no teu caso é instalar uma interface e um gerenciador de login via “chroot”, e não esqueça de ativar esse gerenciador de login com o systemd. (Imagino que o tutorial que tu está seguindo tenha esse procedimento, se não tiver avisa aqui).

Depois com a interface gráfica instala e ativa o network manager.

PS: Eu nunca instalei a interface gráfica em “chroot”, até porquê pra mim esse procedimento do wifi-menu sempre funcionou de boas. Mas acredito que funcione numa boa.

Para verificar se tem um pacote instalado, basta usar:

pacman -Q | grep nome_do_pacote

2 Curtidas

Instalei o plasma e plasma-desktop, agora não conecta volta a marrar na interface…

E tive de abrir os settings e colocar wlp4s0 no device para funcionar.

Instalou os pacotes?

pacman -S networkmanager nm-connection-editor network-manager-applet

Rodou os comandos (como root)?

systemctl enable NetworkManager.service

systemctl start NetworkManager.service

Talvez precise reiniciar depois desses comandos.

Jedi se usa Arch tbm?

Não, mas já usei por um tempinho e testei algumas vezes.

1 Curtida

Rode o comando para verificar se esta rodando corretamente o serviço.

sudo systemctl status NetworkManager.service

PS: Instalo Arch em 2 notebooks com interface diferente, e não tenho que fazer nenhuma interação para ajustar interface e tal, somente em 1 dos desktop que tenho que instalar o driver broadcom-wl. Acredito que vc tenha feito algo errado na instalação, esquecido de instalar algo ou algo assim, não é para ser complicado assim.

Instalando estes pacotes:
network-manager-applet networkmanager wpa_supplicant wireless_tools dialog

Era para ter problema apenas se tivesse algum driver que não esta inserido no kernel.

1 Curtida

só não instalei o nm-connection-editor, eu acho que so dei start no networkmanager. tenho de voltar ao chroot…

Instalei o Arch noite passada e funcionou tudo como deveria. Inclusive o wifi-menu. Talvez seja alguma incompatibilidade com o teu adaptador wifi.

O “nm-connection-editor” é para ter uma interface gráfica/programa/janelinha de configuração. Deve funcionar sem ele também.

E tu não precisa estar em chroot para dar o enable e start no Network Manager, pode fazer isso no próprio sistema, conectar à internet e depois instalar o “nm-connection-editor”.

voltei ao chroot e dei enable aos serviços, depois dei reboot e funcionou :expressionless: