Drivers Intel - Ubuntu

Bom dia! Sou usuário iniciante de Linux e estou com problemas utilizando meu Celeron N2830.

Em todas as flavors Ubuntu que testei (atualmente estou usando Xubuntu), os jogos em streaming e o próprio YouTube apresentam muitos lags. No caso dos jogos, da muito atraso na imagem, mesmo com a aceleração de hardware habilitada.

Ocorre que ao testar o Chrome OS Flex, ainda via pendrive, os jogos e streaming de video funcionam perfeitamente, sem nenhum travamento.

O que há de errado, então, na utilização da minha distro ? Seria falta de algum driver ? Obrigado!

Olá! Beleza?

Para ajudarmos melhor informe as especificações completa do seu PC.
Explique como estava realizando esse streaming, qual programa está utilizando.
Ao instalar o Xubuntu realizou algum processo de update?
Qual navegador esta utilizando? Testou mais de um navegador para verificar se o comportamento é o mesmo?

Em relação a drivers, o suporte ja vem diretamente no kernel linux tanto para CPU(microkernel) quanto iGPU intel se for o caso que esta previsto na pilha gráfica junto ao mesa drivers e etc.

Em relação a vídeo ai é preciso saber qual GPU exata para ver se o suporte de hardware realmente ativa aceleração de hardware. São vários os níveis de aceleração por hardware e youtube por exemplo utilizando codec cada vez mais atual placas de vídeo antigas não possuem suporte no hardware tendo que jogar para a CPU… daí desequilibra todo o esquema.

O ChromeOS normalmente traz um conjunto maior de codecs atualizadas e componentes proprietários e as vezes se sai melhor. Mas nada que pesquisando você não consiga alinhar e fazer similar em um Xubuntu, por exemplo.
Busque aqui no fórum sobre como examinar e passar as especificações completa do seu PC e retorne aqui com as informações e poderemos ajudar melhor.
#sucessoai

1 curtida

Os travamentos acontecem quando tento abrir vídeo em HD ou Full HD no YouTube/Netflix, bem como ao jogar via streaming no xCloud (serviço de Cloud Gaming da Microsoft).

Testei com Google Chrome, Chromium, Brave, Opera e Edge, todos em suas versões atuais. Em todos ocorrem os mesmos travamentos, a menos que eu utilize no ChromeOS.

O Xubuntu está recém instalado, com o kernel padrão da LTS, fez apenas uma atualização automática pós-instalação.

Seguem as especificações:
Notebook HP 14’ Res. 1366 x 768
CPU: Intel Celeron N2830 2,16 GHz Dual-Core (Arquit. Bay Trail-M)
GPU: Intel HD Graphics - Freq. 313/750 MHz
8GB RAM - DDR3L 1333
SSD 128GB
Sist. Operacional: Xubuntu 20.04 LTS - Kernel 5.4

Para início, tenta o seguinte:

. instale os codecs complementares. Abra o terminal e manda:
sudo apt install xubuntu-restricted-extras

depois de tudo instalado certifique que você tem a última versão do ffmpeg

sudo apt install ffmpeg

depois de tudo instalado ou atualizado
abra o chrome e vai na parte de extensões e instala o enhanced-h264ify e após instalado a extensão e ativo selecione a opção de bloquear vídeo av1, vp9 e vp8. Com isso ficará forçado usar o h264 que as iGPU intel conseguem lidar melhor.
Feito isso fecha tudo, reinicia e faça os teste.
Conta aqui se houve melhora.

2 curtidas

Boa tarde @italovn94 isso acontece porq os navegadores base Chromium (Google Chrome, Opera, Brave e Edge) nas suas configurações e parâmetros padrão no Linux não suportam decodificação de hardware via GPU. Vc pode verificar isso difitando por exemplo: chrome:gpu na barra de endereços. Quanto a questão do Chrome OS Flex acredito que o mesmo tenha a aceleração habilitada visto que é um produto da Google e ela pode ter dado essa atenção especial. Acredito que vc tmb possa verificar digitando na barra de endereços do Chrome no Chrome OS Flex chrome:gpu e comparar.

@aarProTech consegui instalar os pacotes aqui e em relação aos videos melhorou 100%!! Só estou ainda com dificuldade para jogar via streaming, o Chrome ainda trava muito, totalmente diferente do resultado que vejo no Chrome OS Flex… Sigo tentando! Agradeço pela resposta desde já!!

Que bom.
A questão agora é conseguir aperfeiçoar nas configs do chrome.
Como o colega mostrou acima, abre o chrome e digita na barra de endereço:
chrome://gpu

printa a tela e envia.
provavelmente deve estar tudo em modo software.
E esta usando a extensão que falei? Para que o codec h264 seja usado prioritariamente?

Estou utilizando a extensão! Acredito que ela ajudou a melhorar o desempenho no YouTube.
Segue:

Éh… a aceleração por hardware de vídeo não vai rolar. Existe uma penca de métodos para tentar fazer ativar, daí vai ter que ir pesquisando. Aqui no meu caso essa parte do vídeo acelerado no chrome não rolou com a minha iGpu Intel.

Bom, agora sobre os engasgos, quando você toca vídeo no youtube em 1080p60 ele toca normal? abrindo aquele estatísticas para nerds, fica dropando frame ou toca normal mesmo?

Se sim, a questão do streaming pode estar com lags por outros fatores e na maioria das vezes é conexão. Mesmo que sua taxa de download seja alta a questão pode ser rota entre você, provedor e servidor xbox. Ou seja latência e não a questão de banda em si.

Eu falo diversos detalhes sobre streaming e xbox cloud nesses vídeos, vale a pena você assistir por causa dos conceitos e informações sobre “streaming” em si.

Olha eu vou te dar minha opinião final: Seu processador é um pouco inferior ao meu. No Linux ele não vai conseguir rodar streaming de games q executam 1080p 60fps, por conta da falta de aceleração de video no Chrome e demais. Se sua ideia é jogar games em Streaming recomendo que use Windows mesmo nesse seu hardware.

1 curtida

O Chrome até suporta esse recurso, porém é desativado por padrão e nem sempre funciona, aqui no Manjaro com Wayland tá funcionando no Brave, porém a flag --use-gl=egl faz o navegador dropar muitos frames, não só em vídeos na interface tbm, acredito que o recurso ainda esteja em fase experimental e pode levar tempo pra que funcione de definitivo e seja habilitado por padrão.

Ele pode tentar habilitar fazendo o seguinte procedimento:

Abrir o chrome://flags e habilitar as seguintes opções:

  • Override software rendering list
  • GPU rasterization
  • Zero-copy rasterizer

Instalar os drivers do VAAPI da Intel.

sudo apt install i965-va-driver-shaders libva-drm2 libva-x11-2

Iniciar o navegador por linha de comando.

Chrome:

google-chrome-stable --use-gl=desktop --enable-features=VaapiVideoDecoder --disable-features=UseChromeOSDirectVideoDecoder

Brave:

brave-browser --use-gl=desktop --enable-features=VaapiVideoDecoder --disable-features=UseChromeOSDirectVideoDecoder

Após esse procedimento vai ser necessário instalar a extensão enhanced-h264ify e desabilitar os codecs AV1, VP9, e VP8.

Em seguida abra qualquer vídeo da internet e pressione Ctrl Shift I, clique nos três pontos → mais ferramentas (more tools) → mídia (media), se o decodificador for VDAVideoDecoder quer dizer que está funcionando a decodificação por hardware, se for o VpxVideoDecoder quer dizer que está usando o processador para decodificar os vídeos.

Pode funcionar ou não dependendo da versão do navegador portanto não é nada garantido.

4 curtidas

Pra complementar meu comentário anterior acredito que a Google em breve deve habilitar a decodificação via gpu visto que hoje ela já habilitou as camadas aceleradas (rasterização) automaticamente, então acredito que em breve ela deva habilitar essa parte que falta pra o Chrome usar totalmente a gpu pra renderizar e decodificar vídeos pela GPU no Linux.

Tbm espero que seja habilitado por padrão, mas vale ressaltar, as vezes em uma nova versão do Chromium para de funcionar, e depois em uma outra versão volta a funcionar de novo, o suporte pra Wayland e decodificação de vídeo acelerada ainda é experimental eu creio, vai levar um tempo até que esteja 100% funcional.

Animaaaal! Agora funciona perfeito!! Valeu mesmo cara!!

Uma última dúvida: devo sempre iniciar o Chrome via linha de comando? Obrigado!

Não. Veja se o Menu Libre, ou Editor de Menu, está instalado (se não, sudo apt install menulibre), procure o navegador que nas propriedades dá pra editar o comando, aí vc coloca o que o Julio Passou

2 curtidas

Sim, pelo menos até a Google habilitar essa funcionalidade por padrão.

1 curtida

Não sabia dessa utilidade, foi bom mencionar.

1 curtida

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.