Downgrade Wine 4.8 > 4.7

#1

Salve galera, então o wine atualizou recentemente para a versão 4.8 stagging e não estou conseguindo fazer o downgrade dele. Tentei usar o synaptic, forçar a redução mas não estou dando conta, alguem pode me dar uma luz quanto a isso?

#2

não por que alguém iria querer o wine antigo, mas você pode usar o lutris, lá vc usa a versão que lhe agradar.

#3

Tem certeza que não limpou o cahce do apt? Já tentou pelo terminal? O Synapctic apresenta algum erro ou mensagem?

#4

Por que eu to tentando jogar um jogo que não está rodando nessa nova versão do wine

Eu consegui fazer o downgrade. Deu muito trabalho mas consegui, mas do mesmo jeito continuo sem conseguir jogar. Obrigado

#5

Ih, ai já não sei o que pode ser. Sei que a versão 4.8 é a de desenvolvimento. A versão estável acho que é a 4.0. Qual jogo tá tentando jogar?

#6

seja lá o que for, lutris resolve isso fácil.

1 Like
#7

League of Legends. Andei olhando o reddit e já vi que vou ter que esperar, que o problema é sim no wine mas devido à atualização do lol. Toda vez que sai uma dá pau. Grato

1 Like
#8

Já existe uma issue no bugzilla do Wine com uma discussão sobre isso WineHQ Bugzilla – Bug 47198 – League of Legends 9.10 Crash after champ select

1 Like
#9

Galera agora uma puta duvida, o pessoal la do post do WineHQ fez uma glibc e um wine proprio pro jogo, mas não faço a minima ideia de como compilar os arquivos e instala-los. Tem como alguem me explicar como faz isso?

Does the game still crashes for someone else half of the times even with the fixes?
(In reply to ali.aziritobi from comment #26)

Thank you for fixing this.
But can you explain to a noob how i can use these files to make the game run
now ? I use Playonlinux for instance.Would be great if somebody explains me
how i can make the game run

You need to compile glibc and wine-staging with these patches.
Ask on your distribution forums for how to do it.(In reply to ali.aziritobi from comment #26)

GitHub - M-Reimer/wine-lol: Patched wine-staging with fix needed to run League Of Legends
GitHub - M-Reimer/wine-lol-glibc: "Hacked" glibc needed for wine-lol

#10

Acho melhor você tentar esperar mais um pouco para essa solução ficar mais acessivel, o pessoal do Lutris (o que inclui eu) deve facilitar a instalação do jogo corrigido, e falando desses repositorios, eles são para o Arch Linux e derivados (tem o PKGBUILD).

1 Like
#11

=****, muito obrigado pela atenção brother!!

1 Like