Deepin "comeu" 20GB do meu HD

Olá à todos!

Fiz uma instalação UEFI do Deepin no meu pc de testes.
Após isso formatei o pc normalmente e instalei o Win 7 em Legacy.
Para a minha surpresa sumiram 20GB do meu HD de 320GB (Ficando apenas 300GB) e na escolha de boot aparece uma partição chamada Deepin, mas ela está vazia. No GPARTED não aparecem mais partições.
Formatei o HD, reparticionei, mudei para MBR, GPT mas continua na mesma.
Alguém tem alguma idéia?


Imagem do GPARTED


Imagem da seleção de boot.

1 Curtida

Tenta ver com cfdisk

cfdisk /dev/sda

Não entendi muito bem o problema…

1 Curtida

Então… Nenhum particionador que usei até o momento me mostra esta partição de 20GB que o Deepin criou.
Eu havia modificado a BIOS para o processador ser reconhecido como 64bits. Instalei o Deepin utilizando a opção de “usar o disco todo”. Então ele criou os particionamentos tudo automático.
Quando formatei e flashei a BIOS correta que fui perceber que haviam sumido estes 20GB. Nenhum particionador até o momento me mostrou esta partição.
Porém apenas tentei SO de 32bits.
Estou tentando reinstalar o Deepin para ver se o HD é reconhecido por completo. Aí minha idéia será “quebrar” o Deepin formatando as partições por ele mesmo para que depois eu formate o HD completo com outro SO.

PS: O HD é de 320GB

Estranho…

Como vc citou, veja se com a partição completa estará aparecendo o 20G

Acabei de ver… Não está!
Abri o GPARTED pelo Deepin e ele só reconhece os 300GB.
Inclusive estou duvidando da minha sanidade e começando a aceitar que o HD sempre foi de 300GB, porque eu sempre via 320GB no disco, se você jogar o modelo do HD (Hitachi HTS543232A7A) na infernet, você verá que é um HD de 320GB.
Fora que não tem lógica um HD ter 298,09GB de espaço total, pois não é múltiplo de 1024…
Só sei que eu tô olhando aqui pro Deepin e perguntando onde ele escondeu o resto… rs

Estou falando que a minha sanidade anda duvidosa… rs

Resumindo, 320072933376 bytes é igual à 298,09 gigabites…
Aff! Me desculpe a Vergonha! rs

Mas continuo sem saber como tirar aquele “Deepin” da seleção de boot… Alguém?

Desencana cara, isto é padrão da indústria no próprio boot é informado a diferença de tamanho infelizmente é a realidade.
faça aí

dmesg | grep logical

Essa diferença não é no Deepin se você olhar o mesmo HD no Windows a informação será a mesma.

Quanto ao deepin, se seu particionameto foi EFI, você deve excluir o diretório do deepin da partição EFI e depois atualizar o grub para que ele não adicione no boot, assim vaí desaparecer do firmware EFI também.

PS: Se seu firmware aceita EFI, utilize a tabela GPT/UEFI utilizar BIOS é matar a tecnologia da placa, abrindo mão de algumas vantagens que o UEFI trouxe.

1 Curtida

As fabricante calculam os HD como múltiplos de 1000 ao invés de 1024.
Tem uma forma de apagar o setor de MBR do HD usando “dd” só que deixa isso quieto.

*# dd if=/dev/zero bs=512 count=1 /dev/sdX
Substitua "/dev/sdX por “/dev/sda” que é o seu disco.
Com isso você perdera tudo que você tem no HD ate mesmo a MBR.

1 Curtida

Fala @aguamole tudo beleza?

Só um pequeno “aviso” DD é um comando bastante destrutivo, então é MUITO importante usar com cuidado e 110% de certeza do que está fazendo.

E dependendo do tamanho do disco… isso pode demorar algumas horas.

:vulcan_salute:

1 Curtida

Entra na BIOS, vai em boot e remove de lá.
Geralmente as BIOS EFI possuem estes menus separadamente.
Direto pelo Linux, veja essa dica do 4Fasters

1 Curtida

Verdade se usar errado é destrutivo mais esse comando desta forma que eu passei para ele so vai escrever nos primeiros 512byts então é bem rápido.

1 Curtida

Se nenhuma das opções citadas funcionarem

segue um outro caminho pelo efibootmgr, mas recomendo prestar atenção.

Para remover entrada do BOOT da BIOS

Instale efibootmgr:

sudo apt-get install efibootmgr
sudo pacman -S efibootmgr

Habilite um o suporte efi do kernel

sudo modprobe efivars

Então execute sudo efibootmgr para checar as entradas. O retorno vai ser parecido com este:

BootCurrent: 0004
Timeout: 2 seconds
BootOrder: 2001,0003,0005,0006,0000
Boot0000* Lenovo Recovery System
Boot0001* EFI Network 0 for IPv6 (B8-88-E3-84-F3-EF)
Boot0002* EFI Network 0 for IPv4 (B8-88-E3-84-F3-EF)
Boot0003* Windows Boot Manager
Boot0004* EFI USB Device (SanDisk)
Boot0005* ubuntu Boot2001* EFI USB Device

Então remova a opção que você quer. Neste exemplo, Ubuntu é a entrada 5. o seguinte pode ser chamado para excluir a entrada 5 e removê-la da ordem do boot.

( CUIDADO: Antes de executar o seguinte comando, certifique-se de inserir o número correto da entrada de inicialização)

sudo efibootmgr -b 5 -B
1 Curtida

dd: operando desconhecido "/dev/sda"

Estranho… o endereço (/dev/sda) está correto, porém retorna esta mensagem…

Desde que o HD não fique inválido, não há problemas… O conteúdo pode ser apagado tranquilamente…

Entrei na BIOS e coloquei "disable " mas mesmo assim o infeliz insiste em aparecer…
Deve ser bruxaria! rs

Não deu certo…

EFI variables are not supported on this system.

Será que é porquê eu estou usando um live do Lubuntu 18.04 32bits?

Cara,

tem certeza de que não passa por isso aqui?

https://macmagazine.uol.com.br/post/2008/05/08/entendenda-a-real-capacidade-dos-discos-rigidos-atuais/

1 Curtida

Meu problema está meio que diferente do título… rs

Se você particionou e formatou através do Windows e não desfragmentou o disco primeiro, provavelmente é um efeito colateral de alocamento de slots.

1 Curtida

Na realidade a formatação e particionamento foi feito todo pelo Deepin…
Na hora da instalação eu utilizei a 3a opção (Utilizar Disco Inteiro).

1 Curtida