DaVinci Resolve não está abrindo

Olá, sou novo no fórum porém já tenho algum tempo de experiência no Linux.

O que acontece é que o meu PC não está rodando o editor de vídeos DaVinci Resolve por algum motivo.

Eu o instalo, tudo bem, sem problema nenhum, porém se eu clico no ícone de inicializar o programa nada ocorre.

Se eu digitar /opt/resolve/bin/resolve, ele me retorna isso:

Se estiver difícil para ler segue o texto abaixo:

ActCCMessage Already in Table: Code= c005, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= 2282, Mode=  0, Level=  0, CmdKey= 8, Option= 0
PnlMsgActionStringAdapter Already in Table: Code= 615e, Mode=  0, Level=  0, CmdKey= -1, Option= 0
16.0 (#060) Linux/Clang
Main thread starts: 2BD9AB00
[0x7fe12bd9ab00] | Undefined            | INFO  | 2019-09-30 22:41:29,490 | --------------------------------------------------------------------------------
[0x7fe12bd9ab00] | Undefined            | INFO  | 2019-09-30 22:41:29,491 | Loaded log config from /home/pocket-tiger/.local/share/DaVinciResolve/configs/log-conf.xml
[0x7fe12bd9ab00] | Undefined            | INFO  | 2019-09-30 22:41:29,491 | --------------------------------------------------------------------------------
Error: Fail to load fglrx kernel module!
Error: Fail to load fglrx kernel module!
Error: Fail to load fglrx kernel module!
Abortado (imagem do núcleo gravada)

Configurações do meu PC:

Notebook Dell Inspiron 5547
Linux Mint 19.1 Tessa
CPU: Intel Core i7-4510U CPU Dual-Core @ 2.00 GHz
AMD Topaz XT Radeon R7 M260

Configurações detalhadas:

https://termbin.com/9pwa

já tentou carregar o módulo

modprobe fglrx

se funcionar coloque no /etc/modules-load.d

sudo editorquevcusa /etc/modules-load.d/davinci.conf

e adicone

fglrx

quando vc reiniciar o serviço já estará iniciando junto com sistema

Parece algum problema com a placa de vídeo, no entanto, já temos tópicos no fórum sobre o assunto:

Procure sempre fazer uma pesquisa antes :slight_smile:

https://plus.diolinux.com.br/search?q=davinci%20resolve

Agora que vi… ele está carregando,mas falha

O Resolve não é compatível com GPU AMD, ele até roda com algumas gambiarras, mas não é o cenário ideal.

Tentei o “modprobe fglrx”, o retorno é o seguinte:

modprobe: ERROR: ../libkmod/libkmod-module.c:832 kmod_module_insert_module() could not find 
module by name='fglrx'
modprobe: ERROR: could not insert 'fglrx': Unknown symbol in module, or unknown parameter (see dmesg)

Outra: se eu rodar como “sudo”, ainda falha, mas o retorno é diferente.

ActCCMessage Already in Table: Code= c005, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= 2282, Mode=  0, Level=  0, CmdKey= 8, Option= 0
PnlMsgActionStringAdapter Already in Table: Code= 615e, Mode=  0, Level=  0, CmdKey= -1, Option= 0
16.0 (#060) Linux/Clang
Main thread starts: 0DA7FB00
[0x7fdb0da7fb00] | Undefined            | INFO  | 2019-10-01 21:01:52,086 | --------------------------------------------------------------------------------
[0x7fdb0da7fb00] | Undefined            | INFO  | 2019-10-01 21:01:52,087 | Loaded log config from /home/pocket-tiger/.local/share/DaVinciResolve/configs/log-conf.xml
[0x7fdb0da7fb00] | Undefined            | INFO  | 2019-10-01 21:01:52,087 | --------------------------------------------------------------------------------
Abortado

veja aqui
https://wiki.archlinux.org/index.php/DaVinci_Resolve

O link é do Arch, mas vc pode ver arquivos compatíveis para outras distros.

Veja a tabela

GPU vendor Type Driver OpenGL Documentation Works with DaVinci Resolve
AMD / ATI Open source xf86-video-amdgpu mesa AMDGPU No
xf86-video-ati ATI Not tested
Proprietary xf86-video-amdgpu amdgpu-pro-libglAUR AMDGPU PRO Yes
Intel Open source xf86-video-intel mesa Intel graphics Yes
NVIDIA Open source xf86-video-nouveau mesa Nouveau No
GPU Vendor OpenCL driver Tested version Works with DaVinci Resolve
Neutral opencl-mesa No
AMD opencl-amdgpu-pro-orcaAUR 19.30_838629-1 Yes
opencl-amdgpu-pro-palAUR 19.30_838629-1 Yes
Intel intel-compute-runtime 19.27.13361-1 Core dumped
beignet 1.3.2+12+gfc5f430c-2 Core dumped
intel-openclAUR 5.0.r63503-2 Core dumped
intel-opencl-runtimeAUR 1:18.1.0.013-2 Core dumped
Nvidia opencl-nvidia Suitable, but working on cuda instead?

Estou com um problema similar no Resolve, até ontem tava funcionando de boa, hoje fui abrir, não funciona mais, checando os arquivos de log, vi que ele não está conseguindo identificar algo relacionado ao OpenCL, mas todas as libs necessárias estão instaladas desde sempre…

Alguém tem alguma ideia?

Acabei de descobrir que, por algum motivo estranho, tive que rodar o dkms da NVIDIA novamente, tudo funcionando agora.

sudo dpkg-reconfigure nvidia-dkms-440

Pra quem estiver com dificuldades pra rodar o DaVinci depois da última atualização, fiz um pacote deb dele pra facilitar a instalação, ele já vem com essa correção dos links simbólicos e chama a biblioteca OpenCL automaticamente durante a instalação.

1 Curtida

Agora uso Zorin OS. O problema é o mesmo, mesmo que o Zorin tenha a opção “iniciar usando placa de vídeo dedicada”, no caso a minha AMD Radeon R7 M260

Inclusive eu fiz a instalação do ROCm, mas mesmo assim não adiantou.

Achei um vídeo de um russo que conseguiu rodar o DaVinci Resolve no Arch Linux com uma placa de vídeo parecida com a minha: YouTube

Só que não ajudou muita coisa porque eu não entendi direito

Você precisa instalar o pacote OpenCL compatível com a sua GPU, mas mesmo assim ainda tem treta aí, porque o cara mostrou várias edições em arquivos do sistema.

E qual seria esse pacote? Você tem alguma ideia?

Não, mas se você pesquisar no Google, acha fácil.

Eu dei uma procurada legal e não achei muita coisa. De qualquer forma, eu to usando o Olive agora. Não é a melhor opção por ainda estar em alpha, mas serve para o que eu preciso.

Eu tenho um testemunho sobre o Olive…

Gosto bagaray do workflow dele, acho tudo muito intuitivo, tem todos os recursos que eu costumo usar, suporta plugins de áudio VST, entre outras coisas que eu acho muito boas nele, mas…

Fiz um teste em alguns editores, criando uma animação sem efeitos, usando só pan e zoom, no Resolve, foi perfeito, apesar de ficar com baixo FPS no preview, mas no render foi liso, no KDEnLive, achei mais difícil de reproduzir a mesma animação, mas funcionou bem, com o preview nem fluído, no Olive o preview fica liso, foi super fácil de fazer, até mais do que no Resolve, mas depois de renderizado, ficou engasgado, não sei explicar o motivo, mas é como se tivesse pulado alguns quadros.

Atualização do pacote .deb do Resolve