Davinci Resolve não abre no Manjaro

Tentei instalar o Davinci Resolve no manjaro, como o programa não está no pamac instalei pelo aur usando o yay: yay -S davinci-resolve instalei tudo certinho mas na hora de abrir aparece a tela de apresentação, depois de uns 15 segundos o programa fecha e juntamente com ele todos os processos relacionados a ele. Já reiniciei o computador e tentei abrir o programa outra vez, nenhuma melhora. Tentei obter algum log no terminal mas o programa não atende pelos comandos: davinci-resolve davinci resolve davinci resolve. Alguma ideia?

DaVinci Resolve de Linux exige drivers proprietários bem específicos pra funcionar, especialmente os de OpenCL:

Especialmente os drivers OpenCL da Intel, eles fazem o programa crashar na hora.

1 Curtida

Amigo não entendi esse monte de número, o que é exatamente que eu preciso instalar? xf86-video-amdgpu e amdgpu-pro-libgl? É isso?

Edit: falhei em não colocar aqui minhas configurações hardware, segue abaixo.

$ inxi -Fxz
System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  Desktop: GNOME 3.36.6 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2006 date: 11/13/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  rev: 2 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 81470 
  Speed: 1376 MHz min/max: 1550/3400 MHz Core speeds (MHz): 1: 1446 2: 1331 
  3: 1449 4: 1545 5: 1329 6: 1470 7: 1466 8: 1424 9: 1496 10: 1311 11: 1274 
  12: 1546 
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: XFX Pine driver: amdgpu v: kernel bus ID: 08:00.0 
  Display: x11 server: X.org 1.20.9 driver: amdgpu,ati 
  unloaded: modesetting,radeon resolution: <xdpyinfo missing> 
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.38.0 
  5.8.11-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.8 direct render: Yes 
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus ID: 08:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0a:00.3 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 07:00.0 
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 447.13 GiB used: 33.55 GiB (7.5%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
Partition:
  ID-1: / size: 48.97 GiB used: 15.53 GiB (31.7%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 389.64 GiB used: 18.01 GiB (4.6%) fs: ext4 
  dev: /dev/sda3 
Swap:
  ID-1: swap-1 type: file size: 1024.0 MiB used: 0 KiB (0.0%) 
  file: /swapfile1 
Sensors:
  System Temperatures: cpu: 40.6 C mobo: N/A gpu: amdgpu temp: 42 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1099 
Info:
  Processes: 348 Uptime: 59m Memory: 15.63 GiB used: 2.76 GiB (17.7%) 
  Init: systemd Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1092 
  Shell: Zsh v: 5.8 inxi: 3.1.05

Instalar o driver proprietário da AMD, com os pacotes:

amdgpu-pro-libgl # OpenGL proprietário
opencl-amdgpu-pro-orca # OpenCL para RX 590 e anteriores

Reinicie para completar as alterações.

Em seguida, remover, remover drivers open-source de OpenCL:

opencl-mesa
intel-compute-runtime
beignet
intel-opencl
intel-opencl-runtime
1 Curtida