Controle de brilho não funcionando no Manjaro

A uma semana atrás ele estava com uma mensagem de erro pipocando no systemd falando algo do tipo “Não foi possível ativar o serviço de backlight”, inseri o trecho realçado da imagem a baixo no grub (e atualizaei), o “problema” resolveu, porém o controle de brilho decidiu parar de vez. Tentei tirar o comando que fiz no grub e atualizar, nada. Alguma luz?

Output do inxi -F:

System:
  Host: antonio-81v7 Kernel: 5.15.16-1-MANJARO x86_64 bits: 64
    Desktop: KDE Plasma 5.23.5 Distro: Manjaro Linux
Machine:
  Type: Laptop System: LENOVO product: 81V7 v: Lenovo IdeaPad S145-15API
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40679WIN
    serial: <superuser required> UEFI: LENOVO v: BUCN23WW date: 11/05/2019
Battery:
  ID-1: BAT0 charge: 17.6 Wh (75.5%) condition: 23.3/30.0 Wh (77.7%)
    volts: 7.4 min: 7.4
CPU:
  Info: quad core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
    bits: 64 type: MT MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1238 min/max: 1400/2100 cores: 1: 1222 2: 1222 3: 1291
    4: 1287 5: 1221 6: 1220 7: 1222 8: 1222
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Vega Mobile
  Series]
    driver: amdgpu v: kernel
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org 1.21.1.3 driver: loaded: amdgpu,ati
    unloaded: modesetting s-res: 1366x768
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.16-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
    driver: ath10k_pci
  IF: wlp2s0 state: up mac: e4:aa:ea:d5:3e:0d
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Drives:
  Local Storage: total: 1.11 TiB used: 88.36 GiB (7.8%)
  ID-1: /dev/nvme0n1 vendor: SSSTC model: CL1-3D256-Q11 NVMe SSSTC 256GB
    size: 238.47 GiB
  ID-2: /dev/sda vendor: Kingston model: SA400S37960G size: 894.25 GiB
Partition:
  ID-1: / size: 229.53 GiB used: 27.65 GiB (12.0%) fs: ext4
    dev: /dev/nvme0n1p3
  ID-2: /boot/efi size: 488 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 879.11 GiB used: 60.71 GiB (6.9%) fs: ext4
    dev: /dev/sda1
Swap:
  ID-1: swap-1 type: partition size: 3.73 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 42.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 241 Uptime: 2m Memory: 17.51 GiB used: 1.12 GiB (6.4%)
  Shell: Zsh inxi: 3.3.12

Não adianta perguntar pra mim, já tentei ajudar… o que me ocorreu de muito radical é zerar a BIOS/Firmware pra ver se volta ao erro anterior

Ah, sim - tentou Wayland? Plasma tá rodando relativamente bem nele

1 curtida

Qual a sua desktop?

O parâmetro acpi_backlight=vendor está comentado, você tentou descomentar e atualizar o grub?

Mandei a saída do inxi -F
É um ideapad s145 com um Ryzen 3500U e Vega 7 integrada.

Sim. Mesmo efeito, nada mudou

Faz um teste

sudo systemctl disable [email protected]

E veja se funciona

1 curtida

Na hora que liguei o notebook pra colocar o comando que tu passou, DO NADA voltou a funcionar. Não fiz nada, e o louco voltou a pegar. Vai entender kkkk A mais de uma semana tentando resolver essa zebra e vai assim

Quando descomentou vc reiniciou?

Sim, eu fiz isso 3 vezes, atualizei o grub e reiniciei, não tinha ido. Agora do nada meteu o louco decidiu voltar

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.