Compilar usando cmake

Quero instalar um applet no kde mas precisa compilar ele primeiro, a fonte já vem com um script de compilação e instalação, porém ele da esse erro:

-- The C compiler identification is unknown
-- The CXX compiler identification is unknown
CMake Error at CMakeLists.txt:1 (project):
  No CMAKE_C_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "CC" or the CMake cache entry CMAKE_C_COMPILER to the full path to
  the compiler, or to the compiler name if it is in the PATH.


CMake Error at CMakeLists.txt:1 (project):
  No CMAKE_CXX_COMPILER could be found.

  Tell CMake where to find the compiler by setting either the environment
  variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
  to the compiler, or to the compiler name if it is in the PATH.

Projeto:


Acredito que deve ser algo com o musl, pois instalei o void linux e nunca tive esse problema antes. Não entendo muito sobre complilação, o que eu devo fazer?
Desde já agradeço.

É seguir as instruções do desenvolvedor:

Esse erro não tem nada a ver com o musl. É um erro de falta de dependência, no caso 1) está faltando o gcc, ou 2) o gcc foi instalado em um lugar muito estranho.

É isso mesmo mas eu uso o void linux, eu não sei quais são as dependencias.

Geralmente os nomes dos pacotes são iguais. Alguns casos raros podem ser diferentes, mas nesse caso vc vai ter que procurar nos pacotes por aquele que seja o mais parecido.

Tente instalar os compiladores com:

xbps-install gcc clang{,-{analyzer,tools-extra}} make

Você talvez precise usar parâmetros de busca para instalar o resto das coisas, principalmente os cabeçalhos que provavelmente serão necessários para tudo compilar.

Eu já instalei alguns pacotes que eu acho que são dependencias, mas agora da esse erro:

-- Could NOT find KF5Declarative (missing: KF5Declarative_DIR)
-- Could NOT find KF5Declarative: found neither KF5DeclarativeConfig.cmake nor kf5declarative-config.cmake 
-- Could NOT find KF5Plasma (missing: KF5Plasma_DIR)
-- Could NOT find KF5Plasma: found neither KF5PlasmaConfig.cmake nor kf5plasma-config.cmake 
-- Could NOT find KF5PlasmaQuick (missing: KF5PlasmaQuick_DIR)
-- Could NOT find KF5PlasmaQuick: found neither KF5PlasmaQuickConfig.cmake nor kf5plasmaquick-config.cmake 
CMake Error at /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:218 (message):
  Could NOT find KF5 (missing: Declarative Plasma PlasmaQuick) (found
  suitable version "5.76.0", minimum required is "5.38.0")
Call Stack (most recent call first):
  /usr/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:577 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/ECM/find-modules/FindKF5.cmake:94 (find_package_handle_standard_args)
  CMakeLists.txt:18 (find_package)
-- Configuring incomplete, errors occurred!
See also "/home/nicolas/Pacotes/applet-window-buttons-0.8.1/build/CMakeFiles/CMakeOutput.log".

Quando procuro por pacotes kf5 pelo site, aparece pacotes que já instalei.