Como utilizar interface gráfica GUFW no Debian 10 Buster

Comecei a usar o Debian 10 Buster no meu notebook, já passei pelo Mint, Ubuntu e Pop!_OS, mas só o Debian está me deixando “satisfeito” em usar o notebook, os outros sempre me irritavam com travadinhas chatas rsrs. Meu notebook é um Dell Inspiron 15 5000, 8gb de ram, core i3 sexta geração, ssd Crucial BX 500 480gb. Porém ainda não consegui usar o GUFW pra ativar a configuração básica do firewall. Em primeiro lugar gostaria de saber se é possível fazer uso da interface grafica no Debian, pq vi que ele é mais cascudo pra instalar os apps. E em segundo lugar, gostaria de indicações de material pra aprender a configurar um firewall de forma eficiente. Desde já obrigado a todos.

Na verdade, o gufw é a interface gráfica do ufw.
Para instalar no Debian é bem simples, basta rodar o comando:

$ sudo apt install ufw gufw

Para inicializa-lo:

$ sudo gufw

1 Curtida

Instalar ele instala, mas quando chamo ele no terminal já como root, retorna a mensagem:

Por enquanto não consegui usar a interface gráfica, mas o UFW está instalado e ativei a configuração básica pelo terminal com o comando:
ufw enable

E chequei se estava ativado com:
ufw status verbose

retornou:
Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

Agora é continuar as pesquisas, e aprender sobre configuração de firewall.

Engraçado é que mudei pro Linux no começo do ano, quase voltei pro Windows umas duas vezes, mas tá servindo pra me dar mais foco, porque aprendi a não desistir na primeira frustação. Quando não consigo, ao invés de pensar: Não consegui. Comecei a pensar: Ainda não consegui.

Vc não colocou seu usuario no sudoers não e mesmo ? pra usar qualquer coisa via “sudo” e necessario que vc esteja no sudoers kkkkk
Verifique se o pacote sudo esta instalado e dps digite isso como root usermod -G adm,sudo user (não esqueça de reiniciar a maquina)
Isso vai ativar o sudo e ai vc pode usar a interface do gufw

1 Curtida

Resolvido! Só estava usando o root, e o meu usuário não estava mesmo como sudo.
Valeu @ruanelivelton18 :fist_right:t2: :fist_left:t2:

1 Curtida