Como resolver o problema com OpenCL no Blender e Davinci Resolve em placas AMD - Manjaro e Arch

Não existe nenhuma lib faltando, desinstala o opencl-mesa do manjaro, e instale o opencl-amd-polaris via aur usando o yay ou pamac. Reinicie o pc e faça o teste com Davinci. Acabei de instalar para um amigo meu remotamente, e ele possui uma RX 570 e funcionou com opencl-amd-polaris.

3 Curtidas

Obrigado pela dica, @Danielaustlab, mas o DaVinci persiste não funcionar 100% :disappointed: !

Vamos lá!

  1. Eu não consegui desinstalar o opencl-mesa. Eu tentei executar sudo pacman -R opencl-mesa (e também sudo pacman -R mesa-opencl-icd e sudo pacman -R mesa-opencl-icd-dbg) e o terminal retorna erro de que o “alvo” não foi encontrado. Diante da minha impaciência, já que tive que instalar o Manjaro e tudo novamente, eu prossegui com a instalação do AUR “opencl-amd-polaris”.

  2. Com a instalação do “opencl-amd-polaris”, ocorreu tudo bem - ele conflitou com alguns arquivos que resolvi dando permissão para ele sobrescrevê-los. Coloquei o seu Script nos diretórios certos e alterei o arquivo desktop para meu nome de usuário. Fui testar, então, o DaVinci.

  3. Executando o inicializador criado pela própria instalação do DaVinci, o editor congela ao carregar “Fairlight panel”. Com seu script, o DaVinci funcionou como antes: apenas a timeline da aba Fairlight permanece completamente escuro.

É, mais desanimação pra mim. Vi na descrição do AUR “opencl-amd-polaris” que o driver 19.50 da versão do Ubuntu 18.04.3 é o último que aparenta oferecer suporte para GPU Polaris. Acabei até testando no Pop!_OS essa versão do driver, mas ele sempre corrompida o sistema, tendo que desinstalá-lo pelo tty3.

Agora, tenho umas perguntas para você:

  1. Esse seu amigo que possui uma RX 570, saberia qual é o modelo e marca da GPU dele? :thinking:

  2. Você descreveu no seu post que:

Mas como assim instalar com o “yay” ou “pamac”? :thinking:

Eu apenas executei os comando:

git clone https://aur.archlinux.org/opencl-amd-polaris.git

Naveguei até a pasta que ele foi clonado e executei

makepkg -si

E a instalação se desenvolveu. Como pode ver, eu não executei nenhum “yay” ou “pamac”, portanto, instalei errado então? :thinking:

1 Curtida

A placa do meu amigo é uma XFX RX570 8GB, Modelo:RX-570P8DFD6.

Eu disse para instalar via yay ou pamac pois vc possui os dois instalados para te facilitar, mas o modo que você instalou está correto.

Se vc tiver um microfone aí, me manda no privado seu telegram, skype, discord ou outro software que vc utilize para que possa te guiar melhor, ou até instalar p vc se vc tiver interesse, assim fica mas fácil para eu detectar o problema estando no seu pc.

Para desinstalar bastava usar o comando abaixo

sudo pacman -Rsndd opencl-mesa mesa-opencl-icd mesa-opencl-icd-dbg

Caso queira dar uma olhada nas outras opções do pacman pode dar uma lida no manual do mesmo.

man pacman

3 Curtidas

pedi acesso, to com problemas ainda pra fazer essa rx570 funcionar :confused: ta ■■■■, ja tentei de tudo

1 Curtida

Liberei o acesso ao arquivo novamente.