Como reduzir o uso de memória SWAP?

Estou tentando editar um vídeo bem simples, é apenas um trecho de gameplay de The Witcher 3 que quero mostrar para uns amigos, estou usando o Shotcut, acontece que durante a edição, que se resume em cortar e adicionar um efeito de transição bem simples, a resposta do computador fica muito lenta.

Isso não seria de se estranhar se a máquina fosse bem fraca, mas ela não é tão fraca assim, o hardware é o seguinte:

  • Processador: Ryzen 5 2500U (GPU integrada Vega 8);
  • GPU (dedicada): Radeon 535;
  • Memória RAM: 8GB DDR4;

Estou usando o Linux Mint 19.3.

Em teoria eu não deveria ter encontrado problemas para editar o vídeo, já que o o hardware é ok e o arquivo que está sendo editado está apenas em HD e a 30FPS, verifiquei se o problema poderia ser o uso do processador, mas não é, ele só chegou a usar 50% da capacidade em um momento bem pontual. O uso de memória RAM também estava normal, 3.5GB mais ou menos, mas tinha pouco mais de 500MB sendo utilizados como memória SWAP, mesmo com bastante RAM livre.

Enfim, estou suspeitando que seja esse uso “desnecessário” de SWAP a causa das lentidões e congelamentos, mas não sei se começar a usar essa memória tão cedo é uma configuração do sistema ou se é algo do Shotcut, alguém já passou por algo parecido e conseguiu resolver/atenuar o problema? Agradeço.

De uma olhada, eu estou estudando React Native e to usando emuladores android e usa pra krl da minha RAM e apesar de eu ter 8gb de ram o uso da swap está usando quase que sem necessidade, consegui melhora um pouco com esse link mas não foi muita coisa.

1 Curtida

As vezes os programas de edição usam aceleração openCL ou openGL para acelerar efeitos de vídeos, pode ser que esse seja o causador. Veja se há opção de “desativar aceleração de hardware” e veja se resolve. Como é apenas quando você adiciona efeitos, pode ser isso!

1 Curtida

Então, o Shotcut não tem uma opção com esse nome exatamente, existe uma “aba” chamada “Display Method”, e ela permite escolher entre “OpenGL” e “Software (Mesa)”, fiz alguns testes e as lentidões acontecem independente da opção selecionada.

Vou seguir as recomendações e ver se consigo pelo menos atenuar o problema, obrigado :smiley: