Como mudar o idioma do Manjaro?

Então galera, instalei o Manjaro Gnome em uma máquina e grande parte do sistema está em inglês, alguém faz ideia de como trocar? Quando vou em regiões e idiomas, e clico em “Language”. não aparece nada. Vou deixar meu inxi -Fxz logo abaixo.

inxi -Fxz
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LC_COLLATE = "C",
	LANG = "pt_BR.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  Desktop: GNOME 3.38.3 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME B450M-GAMING/BR v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2006 date: 11/13/2019 
CPU:
  Info: 6-Core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ 
  rev: 2 L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 81469 
  Speed: 3017 MHz min/max: 1550/3400 MHz boost: enabled Core speeds (MHz): 
  1: 3017 2: 1404 3: 1429 4: 1436 5: 1370 6: 2721 7: 1331 8: 1324 9: 2312 
  10: 1348 11: 1353 12: 1957 
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 
  vendor: XFX Pine driver: amdgpu v: kernel bus ID: 08:00.0 
  Display: wayland server: X.org 1.20.10 compositor: gnome-shell driver: 
  loaded: amdgpu note: n/a (using device driver) - try sudo/root 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Radeon RX 570 Series (POLARIS10 DRM 3.39.0 
  5.9.16-1-MANJARO LLVM 11.1.0) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] 
  vendor: XFX Pine driver: snd_hda_intel v: kernel bus ID: 08:00.1 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0a:00.3 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 07:00.0 
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 447.13 GiB used: 9.36 GiB (2.1%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37480G size: 447.13 GiB 
Partition:
  ID-1: / size: 48.97 GiB used: 7.6 GiB (15.5%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 269.5 MiB used: 312 KiB (0.1%) fs: vfat 
  dev: /dev/sda1 
  ID-3: /home size: 389.64 GiB used: 1.77 GiB (0.5%) fs: ext4 dev: /dev/sda3 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 53.8 C mobo: N/A gpu: amdgpu temp: 52.0 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1124 
Info:
  Processes: 314 Uptime: 17m Memory: 15.63 GiB used: 1.96 GiB (12.6%) 
  Init: systemd Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1112 
  Shell: Zsh v: 5.8 inxi: 3.3.01
1 Curtida

Olá @denielt :wave:t2:

No terminal digita:

sudo nano /etc/locale.gen

Ele vai mostrar vários idomas, então você vai descendo até encontrar o # pt_BR.UTF-8 UTF-8 e apaga o #, salva ele com o comando control+o e control+x para sair.
Por fim executa o comando:

locale-gen e reinicia o computador.

Então vai em configurações do gnome > no Regiões e Idiomas

:pray:t2:

1 Curtida

Acabei de ajudar um amigo aqui com esse problema

Depois de tatear, acho que solucionamos assim:

  1. Deixar o sistema todo em inglês pelas configs do Gnome, reiniciar e aceitar a mudança no nome das pastas da home
  2. No Manjaro Settings, configs regionais, remover português, recolocar (pt_BR.UTF-8)
  3. Ainda nele, ir nas avançadas, colocar tudo em pt_BR
  4. No terminal (com esse erro, o terminal não abria, em inglês passa a abrir), mandar sudo locale-gen e sudo localectl set-locale LANG=pt_BR.UTF-8
  5. Reinicia, aceita a mudança de nome de pastas da home que deve resolver

@RuKsu, é bem possível que ao abrir o locale.gen venha em branco, como abaixo:

Desse jeito, acho que resolve

Não esqueça de conferir nas configs do Gnome se deu tudo certo!

3 Curtidas

Eu não sabia deste comando ainda, assim é melhor que ir alterar um arquivo de sistema. É mais direto sem precisar acessar estes arquivos, vai que apaga algo que não é para apagar por acidente e tals… :sweat_smile:

Melhor mesmo um comando direto para isso :laughing:

1 Curtida

Parte disso foi no tentativa-e-erro e parte foi encontrado na Wiki do Manjaro, item “locale”

https://wiki.manjaro.org/index.php?title=Locale

2 Curtidas

Você tá sempre aqui no fórum resolvendo meus problemas, nem sei como agradecer cara hahahaha, sempre me salvando. Obrigado mais uma vez.

3 Curtidas

Deu certo? Aeeeeee

1 Curtida