Como instalo o Discord no deepin? [RESOLVIDO]

#1

Tento instalar pela Deepin Store e por pacote .deb, porém… da erro de dependência quebrada, a ‘’ libc++1".

1 Like

#2

Como se instala eu não sei, mais me falaram que o discord de linux está meio bugado (pelo o que eu entendi).
Boa sorte.

0 Likes

#3

aah sim, tô tendo q usar a versão web dele, por enquanto.

0 Likes

#4

Descreve o procedimento exato que vc está fazendo e cola a mensagem de erro completa aqui pra gente ter uma noção do que está acontecendo aí.

0 Likes

#5

Instala o snapd e instala o Discord por ele.

1 Like

#6

Acho que o problema é com o Discord no Deepin mesmo, tentei instalar ele em 3 máquinas diferentes e ele não roda (Deepin 15.8) , dá o erro de “Dependência quebrada” nessas mesmas máquinas só que com um sistema diferente ele roda (mesmo com os bugs da versão de linux). se não estiver disposto a mudar de distro, tenta usar ele pelo navegador ou baixa o Snapd e roda ele como snap que deve funcionar. (não testei ainda então boa sorte) :slight_smile:

1 Like

#7

Também podes tentar instalar pelo flatpak
No repertório do flathub

1 Like

#8

Se quiseres appimage do discord estou disponível para dar e poderes testar

Nota: não sou que disponibiliza o appimage mas é no servidor oficial do discord de linux tem lá o link

0 Likes

#9

Tu pode instalar o discord via snap/flatpak, mas atualmente o cliente discord para Linux anda dando muita zica independente da distro, recomendo usar pelo navegador…

0 Likes

#10

Agradeço a todos, vou pensar se mudo de distro, se não, fico usando pelo navegador mesmo.

0 Likes

#11

Por navegador, todos os recursos funcionam, chamadas de vídeo, notificações, etc…

Caso esteja usando o Chromium ou um derivado dele, por criar um webapp pra ter um acesso mais fácil.

1 Like

#12

Passo a passo que funcionou pra mim no Deepin:

1 - Instale esta lib: Debian -- Package Download Selection -- libc++abi1-7_7.0.1-6_amd64.deb
2 - Depois instale esta lib: Debian -- Package Download Selection -- libc++1-7_7.0.1-6_amd64.deb
3 - Depois instale esta lib: http s://packages.debian. org/sid/amd64/libc++1/download (retire o espaço entre o p e o s e no .org, coloquei somente porque novos usuários só podem postar dois links por vez)
4 - Instale o Discord da loja Deepin ou baixando do site oficial

5 Likes

#13

estava usando via flatpak mas a sua dica deu super certo vlw

0 Likes