Como instalar software de segurança da caixa e sua dependência

Oi ṕessoal beleza?

Estou tentando instalar o software de modulo de segurança da caixa, que você baixa para acessar sua conta no site da caixa, ao tentar instalar o arquivo.deb no ubuntu 18.04 ele instala sem problema, mas no 19.10 ele diz que precisa instalar algumas dependências.

A dependência em questão é a libssl1.0.0 eu ja fui no google e pesquisei, mas não consegui encontrar.

Alguém ai conseguiu? poderia dar uma ajuda?

1 Curtida

Use o “sudo apt install -f” para instalar a dependência que falta

1 Curtida

Já fiz, mas ele desinstala o pacote ao invés de instalar a dependência.

1 Curtida

Usando o Gdebi gtk vc não tem resultados?
Ate pq parece que o pacote não da suporte as não LTS

1 Curtida

Como você está usando software de terceiros, especialmente um programa fechado, eu recomendo que você fique estacionado na LTS (sai de 2 em 2 anos, atualmente é a 18.04) e só atualize quando vir outra.

No entanto, achei que é possível instalar no Ubuntu 19.10 com sudo apt install libssl1.0.0.

Vou abrir minha VM de Ubuntu para confirmar.

2 Curtidas

Nem assim cara, mas a explicação do @Capezotte fez sentido, talvez o software não tenha suporte para distribuições não LTS.

E @Capezotte este é o retorno ao usar o comando `sudo apt install libssl1.0.0.
caio@aldebaran:~$ sudo Gdebi libssl1.0.0.
sudo: Gdebi: comando não encontrado
caio@aldebaran:~$ sudo apt-get install libssl1.0.0.
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
E: Impossível encontrar o pacote libssl1.0.0.
E: Couldn’t find any package by glob ‘libssl1.0.0.’
E: Não foi possível encontrar o pacote através da expressão regular 'libssl1.0.0

E ao usar sudo apt-get install 'libssl1.0

caio@aldebaran:~$ sudo apt-get install libssl1.0
Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
Note, a seleccionar ‘libssl1.0-dev’ para a expressão regular ‘libssl1.0’
Note, a seleccionar ‘libssl1.0.0’ para a expressão regular ‘libssl1.0’
Note, a seleccionar ‘libssl1.0.2’ para a expressão regular ‘libssl1.0’
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

Obrigado por ajudarem.

2 Curtidas

Tem um ponto a mais no comando.

1.0.0. é diferente de 1.0.0

Inclusive

Eis o nosso amiguinho aí.

1 Curtida

Você baixou o programa direto do site do Fabricante? ou foi através de links que podem estar desatualizados? pois o nome do pacote mais recente 1.13 se chama warsaw_setup, pela captura do seu terminal está instalando a versão 1.12, talvez seja somente este o problema, as distros novas utilizam OpenSSL 1.1.*.
https://www.dieboldnixdorf.com.br/warsaw

2 Curtidas

Baixei o software direto do site da caixa, agora a biblioteca que não tava conseguindo achar.

1 Curtida

Se você baixou do site da caixa o programa está desatualizado conforme falei mais acima, baixe do link do fabricante do software e tente novamente. A instalação e ativação é feita totalmente via browser “não há a necessidade de reiniciar”

Resumindo:
Baixa o pacote direto da diebold, instala o pacote e depois configura a instituição no próprio site da diebold que faz a checagem, instala os arquivos necessários e já ativa o serviço no systemd.
O processo é este, bem simples por sinal.

1 Curtida

funcionou, baixando direto do site ele instalou normalmente.

Obrigado mesmo.

2 Curtidas