Como Instalar o TP-link TL-WN823N V3 USB no linux mint 19.2

Olá pessoal sou novo aqui, e o motivo de estar fazendo esta pergunta aqui é por que já pesquisei bastante e não encontrei uma solução para esse problema titulo do tópico.

Recentemente optei por instalar em uma maquina em casa (trabalho e jogos *rsrsr) o Linux Mint 19.2 tudo ocorreu muito bem mesmo por que já tenho maquinas em meu local de trabalho com o mint e nos damos muito bem porem em casa eu fiz a instalação conectei esse “Adaptado TP-link TL-WN823N V3 USB” que foi prontamente reconhecido mas, o LED de indicação de uso não acende o que já me deixou em alerta e a velocidade fica limitada em 10 megas download (uso um link de 30) sendo que no Windows 10 eu tenho a velocidade total que é 30 com o drive instalado ou não.

No site da TP-link tem até os drives para instalação mas, eu não entendo nada disso e por tando queria pedir a ajuda pra saber se existe alguma maneira de ter um instalador (pacote) ou algo assim pra eu simplesmente clicar e instalar pois ficou meio chato ter velocidade total e não ter como usar por conta de limitação. (tudo por que não manjo nada kkkk)

link dos drives: Click Aqui

Obrigado e desculpem pelo longo texto!!!:sweat_smile:

Os drivers do site do fabricante estão desatualizadíssimos, basta ver que no item 2 da página do driver consta o seguinte: Para o kernel Linux 2.6.24 ~ 4.9.60. O Mint 19.3 usa o kernel 4.15.0-70, portanto já não é mais compatível nem seguro instalar o fornecido pela TP-Link.

O meu adaptador é o mesmo modelo do seu, e eu uso esse driver que já é atualizado p/ os kernels mais atuais.

Pra instalar, é preciso ter uma noção básica de linha de comando, então, segue os passos:

  1. Primeiro passo, abra o terminal e instale as dependências:

sudo apt-get install git linux-headers-generic build-essential dkms;

  1. Segundo, ainda no terminal, baixe o driver:

git clone https://github.com/Mange/rtl8192eu-linux-driver.git && cd rtl8192eu-linux-driver

  1. Terceiro, ainda no terminal, compile e instale:

make;

sudo make install;

  1. Quarto passo, copie e cole esses comandos (uma item de cada vez) pra aplicar as configurações no sistema e carregar o driver durante o boot:

echo “blacklist rtl8xxxu” | sudo tee /etc/modprobe.d/rtl8xxxu.conf;

echo -e “8192eu\n\nloop” | sudo tee /etc/modules;

echo “options 8192eu rtw_power_mgnt=0 rtw_enusbss=0” | sudo tee /etc/modprobe.d/8192eu.conf;

sudo update-grub; sudo update-initramfs -u;

Se tudo deu certo, basta reiniciar o sistema.

Olá amigo, segui todos os paços mas, na ultima linha “sudo update-initramfs -u;” deu o erro abaixo seguidas vezes.

libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/8192eu.conf line 1: ignoring bad line starting with '“options'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/rtl8xxxu.conf line 1: ignoring bad line starting with '“blacklist'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/8192eu.conf line 1: ignoring bad line starting with '“options'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/rtl8xxxu.conf line 1: ignoring bad line starting with '“blacklist'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/8192eu.conf line 1: ignoring bad line starting with '“options'
libkmod: ERROR ../libkmod/libkmod-config.c:656 kmod_config_parse: /etc/modprobe.d/rtl8xxxu.conf line 1: ignoring bad line starting with '“blacklist'

Vai no terminal e digite

sudo lshw -C network

, copie o texto de saída e cole aqui por favor

Amigo segue texto de saída…

*-network
descrição: Ethernet interface
produto: Ethernet Connection I217-LM
fabricante: Intel Corporation
ID físico: 19
informações do barramento: pci@0000:00:19.0
nome lógico: eno1
versão: 04
serial: 34:e6:d7:fc:65:db
capacidade: 1Gbit/s
largura: 32 bits
clock: 33MHz
capacidades: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuração: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.13-4 latency=0 link=no multicast=yes port=twisted pair
recursos: irq:30 memória:f7800000-f781ffff memória:f783d000-f783dfff porta de E/S:f080(tamanho=32)
*-network
descrição: Interface sem fio
ID físico: 1
informações do barramento: usb@3:12
nome lógico: wlxd0374538243f
serial: d0:37:45:38:24:3f
capacidades: ethernet physical wireless
configuração: broadcast=yes driver=rtl8xxxu driverversion=4.15.0-70-generic firmware=N/A ip=192.168.100.22 link=yes multicast=yes wireless=IEEE 802.11

1 Curtida

Tente fazer o seguinte:

sudo modprobe -r rtl8xxxu

e depois

sudo modprobe 8192eu

Então repita o comando

sudo lshw -C network

. Se por acaso a saída tiver driver=rtl8192eu como mostra abaixo
[…]

-network
descrição: Interface sem fio
ID físico: 1
informações do barramento: usb@3:12
nome lógico: wlxd0374538243f
serial: d0:37:45:38:24:3f
capacidades: ethernet physical wireless
configuração: broadcast=yes driver=rtl8192eu driverversion=4.15.0-70-generic firmware=N/A ip=192.168.100.22 link=yes multicast=yes wireless=IEEE 802.11

, é porque o driver foi instalado, mas você fez alguma coisa de errado no quarto passo. Se esta tudo de acordo, tente repetir o quarto passo novamente. Lembre-se de copiar todo o código em cada bloco, na ordem que esta.

1 Curtida

Olá amigo bom dia, então por um breve momento apareceu justamente no terminal a linha onde mostra a instalação com efetiva mas, não aconteceu!!!

Continuo usando o adaptador USB de forma limitada tendo 10 megas de download no máximo sendo que no windows tenho 30 de down (evidentemente instalado) fora que o LED verde de indicação de uso de rede nem acende nele com o mint…

Já formatei instalei o sistema e refiz cuidadosamente todos os paços e não funcionou, enfim vou ter que comprar outro adaptador e deixar esse na gaveta vou pegar um da Dlink de 300mbps (Modelo DWA-131) quem sabe não tenho mais sorte rsrsr…

Se tiver uma indicação de um modelo USB de 300mbps que possa ser instalado completamente sem limitação no mint ficarei agradecido!

Obrigado pela força amigo :+1:

1 Curtida

Olá amigo, finalmente consegui instalar corretamente tanto o modelo TP-link TL-WN823N V3 quando o TP-link TL-WN821N V6… já explico essa parte do wifi 821N :joy:

Quebrando a cabeça esbarrei neste tutorial para o fedora (Link Aqui) lendo o tutorial consegui entender melhor o que significava todas as etapas de instalação porem logo no começo o autor deixa o link original de onde ele estudou o processo e fez o próprio tutorial que é este (Link Aqui).

Logo comecei a ler como instalar apartir de “Building and installing using DKMS…” do item 5 em diante voltei a repetir o processo e no item 7 (Force RTL8192EU Driver to be active from boot) que eu percebi que o drive estava instalado mas, no boot não carregava e sendo assim segui até a etapa 10 e agora sim instalado e funcionando perfeitamente pois antes tendo um link de 30 megas de download só conseguia usar entre 9 e no máximo 12 megas.

Sobre o TP-link TL-WN821N V6 é que eu comprei ontem achando que o problema erá o 1º modelo que tenho aqui (TL-WN823N V3) e agora que percebi que era somente o drive que não carregava no boot sabe-se lá o por que :rofl:

Agora tenho 2 Wifi USB ( TL-WN823N V3 e TP-link TL-WN821N V6) funcionando no Linux Mint 19.2 kkkkkkkk…

Espero que este post ajuda outras pessoal com a mesma dificuldade que enfrentei em quase uma semana de sofrimento afff…

Mais uma vez obrigado pela força!

3 Curtidas