Como instalar a versão mais atual do Adobe Brackets?

linux-mint
#1

Olá. Sou desenvolvedor web e gosto muito do editor “Brackets” da Adobe. O problema é que se eu instalo por .deb ele da um erro de dependência e se instalo pelo gerenciador de aplicativos do Linux Mint (que lá diz que está na versão atual) quando abro continua pedindo para atualizar para a última versão, alguém que usa esse editor sabe como instalar corretamente ele no Linux e com a versão atual (1.13)?

0 Likes

#2

O problema do Brackets é que eles ainda não atualizaram as dependências do pacote, ele chama a libcurl3, mas essa lib não está mais disponível em nenhuma distribuição atual, o jeito é aguardar uma atualização ou abrir uma issue lá no Github.

1 Like

#3

Obrigado pela informação.

0 Likes

#4

Fiz alguns testes aqui, desempacotando na mão e rodando localmente o Brackets, ele funciona normal com a libcurl4, ou seja, não tá instalando por relaxo da galera mesmo.

Vou empacotar e por no repositório do RaDiX.

0 Likes

#5

por isso prefiro o Visual Studio Code Code

1 Like

#6

Rodando liso…

0 Likes

#7

Sim, o meu também consigo fazer a instalação, porém ali do lado ainda fica dizendo que tem atualização.

0 Likes

#8

Eu não costumo consumir coisa vindas da Microsoft, mas vou testar depois.

0 Likes

#9

Aqui tá rodando na última versão.

0 Likes

#10

Olha ali no canto superior direito da janela do programa, tem uma caixinha verde, na sua print mostra:

Captura%20de%20tela%20de%202019-02-06%2022-37-29

1 Like

#11

A atualização é só pra Windows… (¬_¬)’

1 Like

#12

Tb ñ costumo ter ferramentas microsoft, mas tenho aberto exceções qdo eles se dedicam ao código aberto, como é o caso. A ferramenta original, q continua fechada e é bem pesada, parecendo um eclipse, é bem diferente, esse parece mais com o Atom e o Sublime Text.
Pode ir com fé, software livre sempre é bom.

1 Like

#13

Pra instalar o brackets mesmo, tive de incluir um repo deles, mas é só um pacote deles, as dependências, trocentas delas, tinha nos repos oficiais da minha distro (Fedora), praticamente todas do node.js, só uma q ñ.

1 Like

#14

Se não se importar com a lerdeza pra iniciar use a versão para flatpak : Flathub—An app store and build service for Linux

ou outro editor como Sublime, Atom, Blue Fish whatever.

1 Like