Como iniciar com o Numlock ativado no ubuntu 19.04?

não achei nada que funcione. Quero que o numlock ligue para que eu não fique tendo que clicar no botão o tempo todo.

O numlockx está instalado?

Sim ele está instalado.

Se o numlockx já está instalado, pule para a segunda parte do tutorial abaixo.

Opa, tudo bem, não consegui fazer ainda, pois ele direciona para uma pasta do unity.

por esse tutorial acredito que seja possível resolver seu problema
https://www.edivaldobrito.com.br/iniciar-com-o-numlock-ativado/

Esse é o mesmo tutorial que postei acima e que, no caso dele, não resolveu…

1 Curtida

sei que pode ser uma pergunta simples, mas quando você tentou abrir o arquivo pela linha de comando qual foi o problema apresentado no terminal?

É o problema que no tutorial, o arquivo que ele pede para modificar é o do unity. E eu uso o Ubuntu com gnome.

No ubuntu 19.04 não funciona. Que triste.

2 Curtidas

1º - Abra um terminal

2º - Rode o comando sudo -i

3º - Insira o comando xhost +SI:localuser:gdm

4º - Por fim, su gdm -s /bin/bash

5º - Rode o comando gsettings set org.gnome.settings daemon.peripherals.keyboard numlock-state 'on’

1 Curtida

@Hornetman Uma dúvida, antes de falar algo:

Tu quer o Numlock ativado após o sistema iniciar, na hora do login ou depois do login?

1 Curtida

E no Fedora como deixa NumLock ativado ao iniciar o sistema?

1 Curtida

Gostaria que o numlock fosse ativado na hora do login.

No XFCE aqui o sistena ativa o numlock após o login só precisar ativar essa opção não sei se isso seria útil para você

1 Curtida

Se os esquemas que você fez até agora não deu certo e você quer ativar o numlock após o login, você pode tentar este esquema (usando o próprio numlockx):

Assumindo que o numlockx já está instalado, faça um shell só pra fazer o comando mais fácil:

echo -e "#/bin/bash\n\nnumlockx on\nsleep 2\n" | sudo tee /usr/bin/numlockx_on
sudo chmod +x /usr/bin/numlockx_on

Agora se não existir (que eu acho difícil) crie a pasta autostart e depois um arquivo *.desktop:

mkdir -p ~/.config/autostart
touch ~/.config/autostart/numlockx_on.desktop
chmod +x ~/.config/autostart/numlockx_on.desktop

Por fim, faça este comando para adicionar o conteúdo no arquivo *.desktop:

cat >> ~/.config/autostart/numlockx_on.desktop<<EOF
[Desktop Entry]
Type=Application
Exec=numlockx_on
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[pt_BR]=numlockx_on
Name=numlockx_on
Comment[pt_BR]=
Comment=
EOF

Sim, este último é um comando só, copie e cole o conteúdo no Terminal

OU

Simplesmente baixe este arquivo que criei e execute que ele irá fazer o resto:

wget https://github.com/elppans/customshell/raw/master/numlockx.sh
chmod +x numlockx.sh
./numlockx.sh
1 Curtida

Acabei de testar aqui e vou editar a dica, pois pra mim deu certo tirando o xterm do comando, guenta ae

Já editei, vê aí se dá certo

Como eu deixo habilitado no fedora?