Como habilito o Vulkan?

Como eu faço para habilitar o Vulkan?

Se o driver da sua GPU tem Vulkan é só sair usando.
Agora se eu não entende a pergunta explica melhor.

Acho que o driver da minha GPU não tem o Vulkan. É uma 00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)

Intel graphics

Será que existe alguma forma de instalar o Vulkan?

Não só existe a possibilidade do driver ser atualizado e a nova versão ter suporte ao Vulkan.
Ae mesmo agora eu lembrei tem pacote de Vulkan para instalar no Ubuntu o Mint é baseado no Ubuntu deve ter também.
Espera um pouco que já aparece alguém que usa GPU Intel.
O OpenGL é Vulkan é para GPU Intel é fornecido pelo driver Mesa3D.


Para mim não faz nenhuma diferença esses pacote Mesa =Vulkan estar instalado porque o meu Vulkan é fornecido pelo driver proprietário da Nvidia.
Mais a Intel fornece os driver das suas GPU através do Kernel Mesa3D e Xorg.
Esses 2 pacotes do Vulkan já vieram na minha distro.

1 Curtida

Muito obrigado. Faz tempo que estou tentando instalar esse pacote, eu uso kubuntu, mas não estou conseguindo achar. Já as atualizações, não a atualizações pro meu drive no momento. espero que logo incluam o Vulkan. Espero mesmo que alguem que consiga usar o vulkan na gPU intel apareça :smiley:

Para Intel, em tese o Vulkan já vem no MESA Driver, mas ai vc precisar ver se a iGPU (a placa de vídeo do seu processador) tem suporte completo ou incompleto para o Vulkan. Se vc precisar, veja o site oficial da Intel, APIs suportadas para controladores gráficos Intel®, e veja se a sua iGPU ta nesta lista e como ta classificada. Se a sua iGPU tiver na lista das “com suporte incompleto”, ter o mesa atualizado não vai lhe ajudar muito.

1 Curtida

Como já falaram, se tiver suporte aí consegue usar. Instala libvulkan1, libvulkan1:i386 e vulkan-tools para garantir. Mas dá uma olhada nesse post do @CanalOCaraDoTI https://www.diolinux.com.br/2019/02/aprenda-deixar-o-ubuntu-e-o-linux-mint.html que explica direitinho.

1 Curtida

Cara não é tão simples assim na pratica as desenvolvedoras simplesmente podem ter abandonado o suporte da GPU e deixado os usuário a própria sorte.

1 Curtida

Dei uma olhada no site, mas meu lspci não mostra nenhum dessas GPUs

VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller

Essa seria a minha GPU, certo?

Genericamente sim, mas tem um modelo específico que impota, procura na descrição do seu processador o modelo dela, pelo ARK Intel. Esse modelo que vai dizer se é compatível , por exemplo Gráficos UHD Intel® 630 ou Gráficos HD Intel® 3000, que você tem que procurar na lista do link do @CanalOCaraDoTI.

1 Curtida

O meu processador é o [Processador Intel® Core™ i3-380M] se segundo o ark a praca de dele é Gráficos HD Intel® para gerações anteriores de processadores Intel®;

Infelizmente acho que não tem o Vulkan para minha GPU T-T (vou continuar jogando meu Dont Starve com lag mesmo)

Obrigado pessoal @lucassfank @CanalOCaraDoTI

2 Curtidas