Como fazer um driver antigo funcionar nas versões recentes do ubuntu?

Gostaria de saber como portar um driver da versão 18.04 para a versão 20.10 do ubuntu

O driver em específico é referente ao leitor biométrico e pode ser conferido nesse link aqui.

Com a melhora do suporte a leitores digitais na próxima versão do ubuntu, torna-se interessante aumentar o suporte de hardwares para melhorar a experiência do usuário, principalmente os mais novatos.

[UPD8]
Para criar um driver, é preciso conhecimento em C.
No link a seguir tem a documentação para quem quiser consultar.
https://tldp.org/LDP/lkmpg/2.6/html/

2 Curtidas

pela minha humilde experiencia anos atrás, depende de quem criou o driver e se pode ser recompilado na sua distro. se for rpm ou deb, tente instalá-lo e satisfazer as dependências, se houver.

se usa pacote deb, pode tentar reconstruir o pacote com o apt. tem tutoriais na internet.

1 Curtida

Obg pela resposta

Mas vc diz usando um apt install -f ?

como disse, depende da “idade” do pacote. às vezes é possível reconstruí-lo com apt ou rpm. às vezes não dá, por causa do gcc ou libs muito diferentes.

pode ser o install -f. s n houver nenhum problema de versões das dependências, pode dar certo. disse “pode”. mas só tentando para ver.

faça:

$ sudo dpkg -i pacote*deb

rpm não me lembro. e outros formatos n sei dizer.