Como faço para instalar o AdobeAir no Linux?

Gente, se já tiver, me mandem o link pra eu aprender… mas, caso não tenha.
Como faço pra instalar o adobe air.bin?


https://help.adobe.com/pt_BR/air/build/WS5b3ccc516d4fbf351e63e3d118666ade46-7fee.html

Sei lá se é isso o que você quer exatamente, eu só pesquisei “adobe air.bin”

1 Curtida

Tentei já e não consegui instalar o app, amanhã eu vou mostrar o erro que aparece quando eu tento. Boa noite

O que você quer instala exatamente?

1 Curtida

https://atelier801.com/topic?f=5&t=166552&p=1#m2



quando aparece isso, o que eu faço?

eu não consigo instalar UM JOGUINHO SIMPLES, o jeito é voltar pra windows mesmo com ele sem atualizações de segurança

O aplicativo Adobe AIR não pôde ser instalado. As ferramentas Debian para criação de pacotes deb (como dpkg-deb ou ar) não foram encontradas no sistema.

dá esse erro agora

Para mim não apareceu a primeira imagem que você postou…
Qual distro você está utilizando?
O comando sudo ./AdobeAIRInstaller.bin retorna este erro?

1 Curtida

eu acho que consegui instalar o adobe, porque apareceu aqui o adobe air na lista de aplicativos, mas agora surge um novo problema… quando eu abro o Transformice.Air, ele aparece normalmente a aba de instalar aplicativo, dou continuidade e tudo mais, mas quando começa a porcentagem de instalação ele dá um erro que é o : O aplicativo Adobe AIR não pôde ser instalado. As ferramentas Debian para criação de pacotes deb (como dpkg-deb ou ar) não foram encontradas no sistema.

uso o linux mint de 64 bits. na XFCE

O tutorial é de 2012, a versão do adobe air era 2.6 (ultima disponivel é 32). No site do jogo indica somente o executável em windows.

Acho que esse tutorial está superado.

Por favor, leia este tópico para obter mais informações sobre este novo Standalone: Topic-164808

Você pode baixar a versão Linux aqui: http://www.transformice.com/Transformice.air

Você precisa fazer o download e instalar o Adobe AIR para que a versão funcione!

2012 foi quando lançou o stadoline, o jogo é atualizado automaticamente, a respeito do adobe air, o 2.6 pelo que eu entendi, foi a última versão pra linux lançada.

Ou o Adobe AIR não foi instalado corretamente ou o seu dpkg está zuado…
Primeiramente desinstale o Adobe AIR.
Não tenho muitos conhecimentos na desinstalação de app de fora do repositório, porém acredito que este comando dê um jeito:

sudo apt-get purge adobeair-2.0.0.xxxxx

PS: Substitua o 2.0.0.xxxxx pela versão correta instalada…

Agora vamos instalá-lo novamente de outra fonte:

wget -O adobe-air_amd64.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_amd64.deb
sudo dpkg -i adobe-air_amd64.deb
sudo apt-get install -f && rm adobe-air_amd64.deb

Veja se funciona…



Desculpe o erro!

sudo apt purge adobeair-2.0.0.xxxxx

Faltou o apt…

:sweat_smile:

O Windows 10 tem atualizações de segurança, se isso for motivo pra vim pro Linux você precisa procura outro se procura algo um pouco mais seguro ai sim o Linux vai te ajuda mas por atualizações de segurança você ta no SO errado então.

Se você quer instala o transformice instala pela Steam que é mais fácil. Não foi você quem fez um tópico pelo mesmo motivo?
Formata de novo pra uma distro 64bits pro xfce e instala pela Steam é o jogo original e é de graça bem mais simples.

deu certo, desinstalei e instalei esse adobe air seu, mas o mesmo erro continua quando vou instalar o transformice. então o problema não é o adobe air e sim esse tal de dpkg-deb



o problema da steam é que eles fizeram o jogo de uma forma que sempre trava quando troca de sala, no oficial do windows ele não trava.
o windows 10 explode meu pc, eu abro o edge e já trava. eu fui pro 8.1 e pro 10 antes de ir pro linux mint, e ambos travam só de iniciar o windows, e eu amei o linux mint

Tentei instalar aqui…
Por um acaso, estas mensagens apareceram para você também depois do comando:

~$ sudo dpkg -i adobe-air_amd64.deb
A seleccionar pacote anteriormente não seleccionado adobeair.
(Lendo banco de dados ... 442463 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar adobe-air_amd64.deb ...
A descompactar adobeair (1:2.6.0.2) ...
dpkg: problemas com dependências impedem a configuração de adobeair:
adobeair depende de libbz2-1.0:i386.
adobeair depende de libgtk2.0-0:i386 (>= 2.6).
adobeair depende de libnss3:i386.
adobeair depende de libxaw7:i386.
adobeair depende de libxslt1.1:i386.

dpkg: erro ao processar o pacote adobeair (--install):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 adobeair

Mesmo com estes erros aqui também instalou o Adobe AIR e o mesmo erro apareceu ao tentar instalar o jogo…
Estou resolvendo as dependências para ver se resolve o problema…