Como configuro o geany pra java?

Queria saber como configurar o editor Geany pra java ele fica dando esse
erro: java.lang.ClassNotFoundException sou muito novo nele e ainda não consigo mexer nessa parte das configurações se alguém puder me ajudar agradeço.(estou usando o Openjdk 11)

Cara eu não sei exatamente como resolver seu problema, mas um conselho que te dou (principalmente quando de trata de compiladores) é instalar seus programas tudo por snap ou flatpak (recomendo mais o flatpak) pq existe muito conflito e configuração desses pacotes java de openjdk com versões diferentes e tal, sempre da problema e nos pacotes snap/flatpak eles já vem fechadinhos pronto pra usar sem precisar configurar nada.

No flathub vc encontra o geany: Flathub—An app store and build service for Linux

Talvez tenha tbm pra snap. Tente instalar em algum desses pacotes e veja se continua seu problema.

O erro é ao executar o Geany ou ao executar um código no Geany?