Como abilitar Saída de som digital 5.1 no linux

Oi pessoal, eu tenho uma placa de som Sound Blaster Audigy RX, em um computador que até pouco tempo atrás usava dual boot com Windows, mais agora está somente com o Ubuntu 19.04, o problema é que no sistema não aparece opção para áudio digital 5.1, somente digital estéreo, tentei verificar pelo alsamixer, mais lá também não existe a opção channels, alguém tem alguma idéia de como resolver ?

manda prints das opções mostradas no gerenciador de som/dispositivos de saida

Nesse momento não tenho como mandar print, mais basicamente só aparece uma opção para som digital estéreo e trocentas opções para som analógico 4,5 e 7.1

Já tentou pelo Pavucontrol? https://i.stack.imgur.com/T8iRm.png

Sim, não é uma questão de mudar alguma configuração, o linux parece ignorar ou não reconhecer a possibilidade do som 5.1 no modo digital, tentei também instalar a firmware do Alsa para testes, mais nada, nada que eu tenha tentado funcionou e como a própria Creative não dá qualquer suporte a isso (me responderam dizendo use o Windows 10), estou totalmente perdido aqui.

Tenta instalar o alsa-utils e o alsa-plugins

Depois de perguntar muito por aí, uma pessoa lá do trabalho acabou me explicando como fazer isso, vou deixar a resposta aqui caso alguém acabe com o mesmo problema.

1 - acesse o arquivo de configuração do pulse audio

 sudo gedit /etc/pulse/daemon.conf

2 - procure pelas seguintes linhas:

 ; default-sample-format = s16le
 ;default-sample-rate = 44100
 ;default-sample-channels = 2
 ;default-channel-map = front-left,front-right

3 altere as seguintes linhas removendo o comentário “;” e deixando desta forma.

  default-sample-rate = 48000
  default-sample-channels = 6
  default-channel-map = front-left,front-right,front-center,rear-left,rear-right,lfe

4 opcionalmente se você quiser aumentar o BASS, caso vc possua um SubWoofer passivo, altere esta linha:

  ;enable-lfe-remixing = no

deixando assim:

 enable-lfe-remixing = yes

pronto, reinicia a máquina e vc terá som 5.1

1 Curtida