Coisas que me falta para poder usar o Deepin como distro padrão

Estou testando o Deepin numa VM e estou interessado em instalar numa partição pra usar, como vou ter que remover 2 outras distros pra instalar o deepin que mede mais de HD, vou precisar que ele supra algumas necessidades então se alguém poder me ajudar ficaria grato, estou perdendo um tempo com algumas coisas e ainda sem sucesso.

Atualização do Drive MESA, já que o Kernel ainda ta antigo não espero que o Driver MESA já esteja muito atualizado e não consigo adicionar PPA, fora que as PPAs que acho são para ubuntu e não Debian.

A distro é chinesa e mesmo assim não parece vir pronta para escrita Japones como se espera, o Linux quando você muda o teclado para japones ele n escreve em Japones, você precisa instalar Ibus ou Fcitx, não consegui fazer o Ibus funcionar.

Calibragem de cores para que consiga ajustar os níveis de cores e brilho a noite de firma prática. vlw

3 Curtidas

É possível puxar o MESA do Debian Unstable (dá um trabalho… Mas terá algo atualizado). A mesma coisa pode ser feita com o Kernel, puxar o do Ubuntu manualmente (o UKUU não funciona no Deepin).

Tem umas gambiarras para compatibilizar o Deepin com PPA; mas é pedir pra quebrar o sistema. Isso é coisa de Ubuntu!

Quanto ao teclado, peço que envie o relato a eles… pelo Feedback. Como não conheço o idioma, é melhor vc relatar - pois eles podem entrar em contato, e solicitar mais informações.

1 Curtida

Sobre os kerneis, devido a ser baseado no debian stable, você só encontrará os kerneis estáveis e de preferência os lts da vida, já sobre os ppas até dá pra instalar no debian, mas requer certas gambiarras que realmente não sei se vale a pena, aliás nem no ubuntu eu acho que venha a valer realmente a pena os ppas, haja vista que não terá suporte em caso de problemas , claro suporte da distribuição, acho interessante evitar programas que não são empacotados na distro, salvo os snaps e flatpaks da vida, estes podem funcionar sem conflitos de bibliotecas, embora eu mesmo não os tenha usado.

1 Curtida

@Gilmar
@anon48034656
realmente deu muito trabalho, dar apt-gest upgrade com repositorio unstable do debian quebra a distro, e depois de dar um upgrade e instalar o MESA 19.1, como tem muitas biblioteca que ficam em versões diferentes da problema para instalar a steam, ai tem que atualizar o que precisa manualmente, pq o upgrade já n faz mais e não pode dar dist-upgrade, kernel 5.1 com ukuu não starta e 5.0 starta com erro, apenas o nativo do sistema, no final foi possível jogar com bom desempenho mas ainda com bug, mouse ficava saindo da janela e a qualidade da imagem não fico como esperava, provavelmente pela versão do vulkan ou algo do tipo, me surpreendi com o desempenho de um sistema com aquele vizual, POP OS e Kubuntu tem que desativar os efeitos visuais pra conseguir jogar decentemente, Deepin não força minha placa de video mesmo com a transparência padrão e consegue bom desempenho da minha máquina, não é apenas bonito, é bem feito, mas ainda não é o suficiente. preciso conseguir atualizar os drivers e kernel livremente, fora outros programas como wine, lutris e discord que ficam limitadas as versões da loja, o discord ao atualizar da conflito com a versão da loja e tem que baixar o .deb do site e se der upgrade no terminal ele re-instala a versão da loja.