Boot extremamente lento Ubuntu 20.04 LTS (instalação recente)

Olá, galera! Venho pedir a ajuda de vocês porque o boot do meu Ubuntu 20.04 LTS está extremamente lento (até comentei em alguns posts, nunca vi nada parecido). Rodei um pouco pelo fórum em busca de respostas, mas os tópicos relacionados foram abandonados e/ou são muito antigos, além do que meu problema parece ter algumas especificidades em relação aos que encontrei por aí.

Eu rodei os seguintes comandos para procurar o problema:

almi@almijr:~$ systemd-analyze
Startup finished in 8.303s (firmware) + 18.414s (loader) + 14.910s (kernel) + 4min 52.531s (userspace) = 5min 34.161s
graphical.target reached after 4min 52.503s in userspace

almi@almijr:~$ systemd-analyze blame
2min 18.840s dev-sdb3.device >
1min 24.480s dev-loop6.device >
1min 23.931s accounts-daemon.service >
1min 23.234s dev-loop0.device >
1min 16.300s NetworkManager.service >
1min 11.263s polkit.service >
1min 5.016s dev-loop1.device >
1min 3.079s dev-loop2.device >
1min 1.347s avahi-daemon.service >
1min 1.346s bluetooth.service >
1min 629ms dev-loop4.device >
58.647s switcheroo-control.service >
58.643s thermald.service >
58.640s wpa_supplicant.service >
58.639s systemd-logind.service >
44.379s dev-loop3.device >
36.704s dev-loop5.device >
34.764s snapd.seeded.service >
33.213s snapd.service >
31.274s rsyslog.service >
30.155s apparmor.service >
30.068s gpu-manager.service >
29.309s apport.service >
29.100s grub-common.service >
28.741s ModemManager.service >
26.324s systemd-journal-flush.service >
24.959s e2scrub_reap.service >
24.697s secureboot-db.service >
21.991s systemd-tmpfiles-setup.service >
19.225s systemd-resolved.service >
18.805s fwupd.service >
16.418s systemd-backlight@backlight:intel_backlight.service >
13.213s grub-initrd-fallback.service >
12.061s snapd.apparmor.service >
11.732s systemd-timesyncd.service >
10.533s nvidia-persistenced.service >
10.373s upower.service >
10.161s systemd-udevd.service >
9.067s gdm.service >
7.914s systemd-modules-load.service >
7.889s modprobe@drm.service >
7.556s user@125.service >
6.816s bolt.service >
6.705s systemd-tmpfiles-clean.service >
5.939s colord.service >
5.783s systemd-sysusers.service >
5.758s systemd-random-seed.service >
4.375s pppd-dns.service >
4.226s keyboard-setup.service >
3.681s systemd-fsck@dev-disk-by\x2duuid-E087\x2d9C04.service >
3.639s systemd-rfkill.service >
3.448s snap-core18-1880.mount >
3.191s console-setup.service >
3.099s snap-core18-1885.mount >
2.912s systemd-journald.service >
2.680s snap-snapd-8790.mount >
2.674s udisks2.service >
2.560s systemd-udev-trigger.service >
2.502s ufw.service >
2.289s systemd-fsck@dev-disk-by\x2duuid-cd1ae0e8\x2d481c\x2d4fd2\x2daa26>
2.256s snap-gnome\x2d3\x2d34\x2d1804-36.mount >
2.245s systemd-update-utmp.service >
1.782s kmod-static-nodes.service >
1.730s dev-hugepages.mount >
1.730s dev-mqueue.mount >
1.729s sys-kernel-debug.mount >
1.728s sys-kernel-tracing.mount >
1.656s systemd-remount-fs.service >
1.570s systemd-tmpfiles-setup-dev.service >
1.341s snap-gtk\x2dcommon\x2dthemes-1506.mount >
1.330s home.mount >
1.280s systemd-sysctl.service >
953ms snap-snapd-8542.mount >
921ms swapfile.swap >
808ms setvtrgb.service >
684ms systemd-user-sessions.service >
678ms snap-snap\x2dstore-467.mount >
581ms user-runtime-dir@125.service >
452ms kerneloops.service >
397ms openvpn.service >
353ms boot-efi.mount >
157ms user@1000.service >
151ms rtkit-daemon.service >
25ms user-runtime-dir@1000.service >
24ms systemd-update-utmp-runlevel.service >
11ms plymouth-read-write.service >
10ms alsa-restore.service >
4ms sys-kernel-config.mount >
2ms sys-fs-fuse-connections.mount >
961us clean-mount-point@media-almi-Backup\x20Plus.service >
633us snapd.socket >
lines 69-91/91 (END)

almi@almijr:~$ systemd-analyze critical-chain
The time when unit became active or started is printed after the “@” character.
The time the unit took to start is printed after the “+” character.
graphical.target @4min 52.503s
└─multi-user.target @4min 52.503s
└─snapd.seeded.service @4min 17.737s +34.764s
└─snapd.service @4min 17.870s +33.213s
└─basic.target @2min 46.776s
└─sockets.target @2min 46.776s
└─snapd.socket @2min 46.775s +633us
└─sysinit.target @2min 46.557s
└─local-fs.target @2min 46.545s
└─run-user-125.mount @4min 40.808s
└─local-fs-pre.target @31.946s
└─systemd-tmpfiles-setup-dev.service @30.376s +1.570s
└─systemd-sysusers.service @24.592s +5.783s
└─systemd-remount-fs.service @22.089s +1.656s
└─systemd-journald.socket @20.361s
└─system.slice @20.270s
└─-.slice @20.270s

Isso porque antes eu tinha tentado algumas coisas, vendo os tópicos, desabilitando algumas opções, como o plymouth-quit-wait.service, deixando minha inicialização naquele modo texto. Parece que mudou alguma coisa em relação ao tempo, mas não sei dizer ao certo, demorou muito ainda assim. E surgiram coisas novas na lista.

Enfim, alguém pode me ajudar a resolver isso? O computador leva uns 10 minutos para ficar utilizável.

Estou usando o Ubuntu 20.04 LTS numa máquina i5-7200U, com 8gb RAM, 1TB HDD, sistema recém instalado (ontem).
Se reinstalar o sistema resolver, me digam, porque estou disposto a fazer.

isso é pós instalação?
Boot do Ubuntu tende a ficar lento quando instala aplicativos via snap eu percebi isso ate mesmo no SSD

1 Curtida

Sim, eu não instalei nada ainda. Também não entendi, nunca passei por isso.

Eu tenho dual boot - Arch e Ubuntu e também percebi isso quando entro no Ubuntu.

Até rodei um snap list aqui pra ver o que tinha de snap instalado:

almi@almijr:~$ snap list
Name Version Rev Tracking Publisher Notes
core18 20200724 1885 latest/stable canonical✓ base
gnome-3-34-1804 0+git.3009fc7 36 latest/stable/… canonical✓ -
gtk-common-themes 0.1-36-gc75f853 1506 latest/stable/… canonical✓ -
snap-store 3.36.0-80-g208fd61 467 latest/stable/… canonical✓ -
snapd 2.45.3.1 8790 latest/stable canonical✓ snapd

Tava pensando que se fosse isso, talvez instalar a versão mínima resolvesse, mas não tem muita coisa assim…

Levando em consideração as informações que foram passadas por você, saiba que esse problema costuma acontecer quando existe algum problema com o fstab. Existem outros tópicos que foram criados sobre esse exato problema, recomendo que procure por eles. Procurar por “fstab lento” deve ser o suficiente.

Quando vc desativa o snapd chega a melhorar?
“systemctl disable snapd”
“systemctl disable snapd.seeded”
Caso queira ativar e so reverter o disable para enable

2 Curtidas

Fiz aqui e não melhorou nada pra falar a verdade.

1 Curtida