Bluetooth ligando ao iniciar

Olá pessoas, boa noite! Espero que todos estejam bem :smiling_face_with_three_hearts:
Estou com um probleminha: Sempre que eu inicio meu notebook, o Bluetooth liga sozinho. Como faço pra isso não acontecer? Uso o Fedora 31

Olá boa noite.
Se você estiver usando o Gnome, basta desativar pelo próprio menu de configurações. Faça isso umas 2 ou 3 vezes ao iniciar o sistema, que o gnome ‘aprende’ que deve iniciar com o Bluetooth desligado. Sempre tratei essa situação assim quando usava o Fedora.
Até mais.

Aqui também acontece a mesma coisa no xubuntu 18.04 e olha que a minha placa de rede nem tem bluetooth a que tinha era a antiga que queimo e eu nem usava ai comprei uma mais simples sem bluetooth e toda vez que ligo aparece o ícone (mesmo não tendo bluetooth) e a opção de desliga e a opção nem funciona kkk ai eu só ocultei o ícone e pronto

systemctl stop bluetooth
systemctl disable bluetooth

Sem o sudo mesmo, os sistemas atuais vão solicitar a senha de qualquer forma, mesmo executando do terminal ou console.

Captura de tela de 2020-01-18 21-55-11

Com isto creio que o rfkill vai desabilitar sem problemas, depois quando precisar reiniciar o sistema verifique se o procedimento funcionou.

rfkill

systemctl status bluetooth

Normalmente é o que basta.

3 Curtidas

Vou tentar, obrigado!

Mas eu quero poder utilizar o Bluetooth. Só não que ligue ao iniciar a máquina.

Sem problemas, o rfkill só vai bloquear via software, você pode ativar quando for usar. isso só não vai carregar como um serviço no boot, costumo fazer o mesmo com o warsaw.

1 Curtida