Arch linux if não aparece a opção de ligin

DUVIDA
Boa tarde, acabei de instalar o arch KDE porém a tela de login aparece mas não tem como colocar o usuário só aparece escolha um usuário e entre com a senha mas não tem como eu digitar o usuário não aparece a opção digitar usuário

Convocando os especialistas @Secret.Fox e @Capezotte

Olá @Gilberto467 :wave:

Se não me engano o KDE não deixa logar no root pela tela de login, ou seja, você precisaria criar um new user pelo CLI.

useradd -m -g users -G wheel "novousuario"

depois setar um password com o comando:
passwd "novousuario"

ambos os casos sem as aspas.

:v:

É possível fazer isso sem ter que reinstalar ? sou novo no arch se isso for possível como faço? Desde já agradeço

1 Curtida

Tenta o comando Control+Alt+F2 ou Control+Alt+F3 para ver.

Provavelmente você criou o usuário mas não definiu senha. Não é possível logar sem senha, então ele só aparece para colocar o usuário.

Como criar um usuário corretamente (com permissão root):

  • useradd -mG wheel nome-de-usuário
  • passwd nome-de-usuário

Não esquece de editar o arquivo sudoers

EDITOR=nano visudo / procura a linha que diz “Uncomment to allow members of group wheel to execute any command” e apaga o # aonde diz “#%wheel ALL=(ALL) ALL”.

Pra entrar em um terminal na tela de login, aperta Ctrl + Alt + F3.

Edit: se você já criou o usuário, é só dar passwd nome-de-usuário

É necessário que você saiba a senha root e faça login como root.

Edit #2: nome de usuário root = root / senha do usuário root = aquela que você definiu na instalação do Arch.

Só uma pergunta por curiosidade: você instalou com instalador ou manualmente?

1 Curtida

Eu instalei manualmente!

Eu consegui do jeito que você falou mas porém quando você faz o login fica na tela preta

E na tele tá escrito >> Starting version 247.2-1-arch
/dev/draw: clean, 279248/3407872 files, 2912849/13631488 blocks tem mais de meia hora nessa tela

Estranho. Como você instalou o Plasma? Você está numa máquina real ou em uma virtual?

Máquina real eu instalei seguindo os passos na arch wik

Eu consegui logar mas fica só nessa tela preta, será que terei que reinstalar?

Qual placa de vídeo está usando? Intel, Nvidia ou AMD?

As vezes precisa instalar o pacote xf86-video-intel para placas intel.

1 Curtida

@Secret.Fox Meu caso por exemplo. Como isso não esta na página do Installation Guide do Arch…

O Arch tem esses detalhes, por ser muito modular existem diferentes formas de tentativas de resolução do problema.

1 Curtida

Pois é, @RuKsu. Aguardando resposta do op.

Fun fact: foi por causa disso que tentei ir no OpenSUSE. Rolling release, mas tudo pré-instalado.

1 Curtida

Minha placa é nvidia

Espera, melhor perguntar qual placa primeiro. Qual placa nvidia você usa?

Dependendo da placa o comando pra instalar é outro.

É uma Gtx 750 ti pcyes

Entra no tty outra vez (terminal da tela de login).

Faz login e baixa os pacotes

  • nvidia
  • nvidia-utils
  • nvidia-settings

sudo pacman -S nvidia nvidia-utils nvidia-settings

Reinicia o pc com sudo reboot e tenta logar outra vez. Deve funcionar.

Ok, vou tentar aqui

Se não der certo vou tentar reinstalar