Arch Linux - Freezing Dell N4030

Olá Pessoal!
Tudo bem?

Até início de 2020 eu utilizava o Arch Linux x86_64 em um Dell n4030, porém após um upgrade de Kernel o mesmo passou a apresentar freezing aleatoriamente. Como estava precisando realizar algumas tarefas não pude pesquisar na época sobre o que poderia estar causando isto… Então instalei o Debian e rodou liso, e contínua rodando até hoje… Este ano, como as coisas estão mais de boa no trampo, resolvi voltar para Arch ou Manjaro, então resolvi testar a ISO live do Manjaro, mas notei que em poucos minutos de uso novamente aconteceu o freezing… :’( Congela tudo, nenhum TTY abre heheheh… Porém com Debian ou POP!_OS roda liso…

Alguém já passou por essa situação?

Seguem configurações da estação:

Dell Inspiron N4030
Processador: i7 620M 2.67Ghz - 6ª Geração
RAM: 8GB DDR3
Armazenamento: SSD 120GB

Essa configuração não é a original, este UP de hw fiz este ano, anteriormente era:

Processador: i3 380m
RAM: 4GB

PS: Fiz algumas tentativas, por exemplo, antes do boot do Manjaro, informar para o kernel desabilitar o PSR, com i915.enable_psr=0, funcinou durante um tempo. Contudo, após cerca de 40min congelou…

Não cheguei a ter esse problema com o Manjaro aqui. Eu tenho um hardware da Dell (bem diferente do teu) mas co Ubuntu e derivados e até o Fedora, ele não funcionava bem.

Só vim ter estabilidade com o OpenSuse. No caso, minha recomendação é essa: fica na distro que deu certo com o seu hardware. Eu tentei de tudo, mas comigo não teve jeito.

1 curtida

Pode ser que seja problema com o kernel.

Se for no Arch, eu recomendo você usar o kernel linux-lts, para ter mais estabilidade. Atualmente ele está na versão 5.10.

No Manjaro, você pode trocar o kernel no Manjaro Settings Manager. Mas também tem outra opção, que é baixar uma ISO já com um kernel LTS, que nesse caso é o 5.4. Só que essa opção de download fica um pouquinho escondida. Aqui está o link:

Esse link vai te levar para a versão com KDE, se quiser com o GNOME ou XFCE, é só trocar “kde” por “gnome” ou “xfce” nesse link aí.

E depois de instalado você desliga as notificações de atualização de kernel no Manjaro Notifier Settings.


Atualização na resposta:

Eu vi recentemente que agora o Manjaro tem uma opção de download da ISO já com o kernel LTS direto na página de downloads. Ficou ainda mais fácil.

O problema deve estar no kernel mesmo… Você precisa registrar as versões que testou.

P.S.: o Core i7 620M é de 1ª Geração, e não de 6ª.

1 curtida

Olá Thiago!

Thank you so much!!! :smiley:

Funcionou perfeitamente, estou usando o Manjaro e respondendo ao post com uso dele!

Vou manter o Kernel somente em LTS…

:+1:

1 curtida

Olá @KairanD, muito obrigado pela observação, realmente é de 1a!

Que bom que deu certo. Fiz apenas uma pequena atualização na minha resposta, para o caso de outras pessoas que virem o tópico, porque essa semana eu vi que agora o Manjaro já tem a ISO com o kernel LTS disponível direto na página de downloads.

Este tópico foi fechado automaticamente 3 dias depois da última resposta. Novas respostas não são mais permitidas.