Apos dual boot fiquei sem audio, alguem pode ajudar?

Boa noite, alguem pode me ajudar? fiz dual boot linux x windows e comecei a ter um problema no som do linux, simplesmente fiquei sem som, de vez em quando o fone de ouvido ou caixa de som fica soltando pequenos estalos como os de quando tem um mal contato(sei que não é problema nos dispositivos de audio pq no windows funciona). atualmente estou usando o manjaro mas testei linux mint, pop os,ubuntu, fedora… enfim, em todos tive esse problema, fiz de tudo, mexi no pulse, em grub e mais um monte de coisas e nada resolveu, o que ainda fez efeito foi tirar a bateria da placa mãe e depois colocar de novo, mas no dia seguinte quando liguei o pc de novo o problema tinha voltado, não penso em mais nada que possa fazer.

Cara, já tentou desconectar e reconectar o cabo? (Assumindo que seja um cabo do tipo Jack). Eu passo por esse problema com um notebook antigo meu, a ligar ou reiniciar com o fone conectado, ele fica mudo e com uns estalos.
Não sendo essa a possível solução para seu problema, dê uma lida neste post e forneça-nos mais informações sobre o seu sistema.

sim sim, ja tentei desconectar, ate tentei inverter os cabos de saida e entrada, tentei ate com um adaptador que serve de placa de audio externa.

aqui mais algumas informações sobre o sistema:

System:
  Kernel: 6.6.34-1-MANJARO arch: x86_64 bits: 64
  Desktop: KDE Plasma v: 6.0.5 Distro: Manjaro Linux
Machine:
  Type: Desktop Mobo: BIOSTAR model: A320MH serial: <superuser required>
    UEFI: American Megatrends v: 5.14 date: 11/05/2020
CPU:
  Info: dual core model: AMD Athlon 3000G with Radeon Vega Graphics bits: 64
    type: MT MCP cache: L2: 1024 KiB
  Speed (MHz): avg: 2006 min/max: 1600/3500 cores: 1: 1568 2: 3486 3: 1370
    4: 1600
Graphics:
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: amdgpu unloaded: modesetting dri: radeonsi gpu: amdgpu
    resolution: 1366x768~60Hz
  API: EGL v: 1.5 drivers: radeonsi,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.1.1-manjaro1.1
    renderer: AMD Radeon Vega 3 Graphics (radeonsi raven2 LLVM 17.0.6 DRM 3.54
    6.6.34-1-MANJARO)
  API: Vulkan v: 1.3.279 drivers: radv surfaces: xcb,xlib
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  API: ALSA v: k6.6.34-1-MANJARO status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active
Network:
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 92.44 GiB (9.9%)
  ID-1: /dev/sda vendor: Toshiba model: HDWD110 size: 931.51 GiB
Partition:
  ID-1: / size: 122.16 GiB used: 87.76 GiB (71.8%) fs: ext4 dev: /dev/sda8
  ID-2: /boot/efi size: 998 MiB used: 296 KiB (0.0%) fs: vfat dev: /dev/sda6
Swap:
  ID-1: swap-1 type: partition size: 6.84 GiB used: 65.7 MiB (0.9%)
    dev: /dev/sda7
Sensors:
  System Temperatures: cpu: 36.6 C mobo: N/A gpu: amdgpu temp: 36.0 C
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 13.6 GiB used: 3.17 GiB (23.3%)
  Processes: 224 Uptime: 15m Shell: Zsh inxi: 3.3.35

isso vindo do comando que mostra no post que recomendou

Ola @Guilherme1, tudo bem?

Pelo descritivo do seu problema, principalmente pelo audio funcionar quando voce removeu a bateria da placa mae mas o problema ter voltado logo em seguinda, acredito que seja conflito com o secure boot e/ou o fast startup.

Eu recomendaria voce tentar desabilitar o fast startup tanto no windows quanto na bios. Para o windows 10 ou 11voce pode seguir o tutorial deste link (em ingles).

Na bios/uefi sera necessario consultar o manual da sua placa mae.

Isso pode ocorrer por que, por padrao, o windows nao desliga completamente. Ele deixa salvo alguns arquivos para iniciar mais rapido e isto inclui o pre carregamento de alguns drivers. Isso a grosso modo. Desta forma, quando voce inicia no linux, o driver ja esta alocado e, por isso, o linux fica sem audio.

Geralmente tive estes problemas quando estava realizando testes em distribuicoes lives, como o Tails por exemplo.

Pessoalmente nao gosto do fast start. Ele economiza, sei la, 10 segundos do tempo de boot. E menos que o tempo de eu ir na cozinha pegar um leite com toddy kkk.

Por ultimo, peco desculpas pela falta de acentuacao. Meu teclado possui layout EN/US e meu SO tambem se encontra configurado neste layout.

1 curtida

Obrigado pela resposta, vou testar isso, na vdd meu windows já esta com o fast startup desligado, mas não mudei nada na parte da BIOS, vou olhar no manual para tentar ajeitar o que for necessario.

tenta essa dica

coloquei na bios como disable mas aparentemente tbm não deu certo, nada mudou.

aparentemente não funciona, quando tento entrar nesse arquivo indicado abre um arquivo vazio.

Se conectar uma placa de som USB resolveria o seu problema ?

usei um adaptador que tecnicamente era pra funcionar como placa de audio, mas ainda ficou sem som.

Muito estranho rapaz, era para funcionar. Essas placas não precisam exatamente de drivers conforme os relatos da galera, tem certeza que na configuração da bios da sua placa-mãe os periféricos onboard estão ativados na categoria USB ?
Já tentou usar o alsamixer no terminal para vê se ele está desabilitado por lá ?


Com a tecla F6 “Select sound card” você pode selecionar o audio

Tenho Trial-boot com essas configurações que é Win11/LM/PepperminOS
Graças ao Fórum DiolinuxPlus, Rikerlinux, linux mint community e o peppermint community (amor de sistema)