Alterar resolução do pop!_OS

Boa noite pessoal.

Hoje instalei o pop!_OS e estava tudo certo, até eu reiniciar o computador, quando ele iniciou a resolução foi alterada, já pesquisei bastante mas até agora não consegui resolver.

Tentei utilizar o comando xrandr , ele resulta isso:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected primary 640x480+0+0 0mm x 0mm
640x480 73.00*

E se eu tentar alterar:
image
Então tentei alterar pelas Configurações, mas não aparece nenhuma opção para alterar quando eu clico na aba Resolução
image

Como posso alterar a resolução?

1 curtida

Olá @matheuuus :wave:t2:

Aparentemente pode ser detalhe com drivers mas, o computador que você está usando qual seria o hardware, Intel, Nvidia, AMD…

Minha placa é uma Nvdia, eu tentei acessar o drive para alterar mas só aparece o aplicativo sem nenhum conteúdo

1 curtida

Entendo, estou fazendo umas pesquisas para tentarmos instalar os drivers da Nvidia ae e fazermos testes. O Pop!_OS é uma excelente distro mas ela tem um comportamento um pouco diferente das que eu conheço. Mas vamos resolver!

1 curtida

Me avisa quando você estiver preparado.

Vamos seguir os procedimentos da System76: Install the System76 Driver - System76 Support

:pray:t2:

1 curtida

As vezes aparece isso em alguns sistemas quando você baixa mas não atualiza. Então tenta fazer isso. Aliás, cuidado com a ISO que você baixa do Pop!_OS por que tem uma pra nvidia e outra pra Intel/AMD.

Tenta usar também o nvidia-settings para ver as suas resolućões, alterar o refresh rate, etc.

1 curtida

Bom dia, desculpe demorar para responder.

Eu segui todos procedimentos, não sei se era pra mudar algo mas não mudou.
Tentei acessar o aplicativo System76 Driver mas ele me mostra isso
image
Eu instalei o pop com a iso no site deles.

1 curtida

Eu atualizei mas não alterou nada, a iso que baixei foi para a nvida mesmo. E o nvidia-settings como falei anteriormente mostra essa tela:
image

Eu resolveria esse problema assim no terminal digite:

xrandr para saber qual a saida do seu monitor

vai aparecer algo como VGA1 connected ou LVDS-1 connected ou HDMI-1 connected etc…

Se a resolução padrão do seu monitor fosse 1920x1080 seria assim:

cvt 1920 1080 60

copie a partir das aspas do modeline Tipo assim: modeline “1920x1080_60.00” 000.00 0000 0000 0000 0000 0000 0000 0000 0000 -hsync +vsync

Adicione a resolução ao xrandr:
xrandr --newmode “1920x1080_60.00” 000.00 0000 0000 0000 0000 0000 0000 0000 0000 -hsync +vsync (Esses dados vai depender do que você obter com o cvt)

Depois:
xrandr --addmode ''Saída do seu video" (VGA-1 ou LVDS-1 ou HDMI-1) 1920x1080_60.00

E agora para que a resolução mude dê o comando:

xrandr --output (VGA-1 ou LVDS-1 ou HDMI-1) --mode 1920x1080_60.00

Depois disso para que a resolução não se perca quando você reiniciar crie um arquivo na sua pasta pessoal assim:

No terminal digite: sudo nano /home/USUÁRIO/.xprofile

Dentro dele coloque os dados da sua resolução:
#!/bin/sh
xrandr --newmode “1920x1080_60.00” 000.00 0000 0000 0000 0000 0000 0000 0000 0000 -hsync +vsync
xrandr --admode (VGA-1 ou LVDS-1 ou HDMI-1) 1920x1080_60.00

Salve o arquivo.

Desculpe não poder mostrar os comandos em minha máquina pois estou no Windows e não posso reiniciar.

Tentei fazer isso mas o xrandr não mostra isso que você falou

tenta baixar uma nova ISO, e verificar se não está quebrada.

Porque realmente isso aí é problema com driver.

Tenta algo simples primeiro: pode utilizar outra porta no seu monitor?

Perdão a pergunta mas só para checar, você chegou a executar o comando
sudo apt-get install system76-driver-nvidia

Utilizei sim

1 curtida

Pior que não, meu monitor só tem uma entrada vga, e não tenho outro monitor em casa para usar

Cara, é um problema que eu nunca vi antes. Muito estranho.

Poderia me dizer duas coisas? Qual é o modelo exato da sua placa de vídeo? E outra coisa, durante a instalaćão do Pop!_OS você consegue ver as coisas na tela?

No Linux há um driver free que não é muito potente mas pelo menos mostra as coisas na tela chamado Nouveau. Ele roda com praticamente todas as placas, mas por algum motivo quando tu instala o driver não funciona. Se a sua placa for muito antiga, é possível que o Pop simplesmente não tenha o driver mais adequado para você (Ex: está instalando o driver 460.xx em uma placa gs 8400; não vai rolar).

Isso acontece comigo aqui em um pc que tem essa placa quando eu tento instalar Arch. Arch é rolling release, e a não ser que eu usei o yay para instalar o driver legacy, dá ruim.

1 curtida

Você poderia executar os seguintes comandos ?

sudo apt install inxi

inxi -G

Isso pode nos dar uma ideia sobre o hardware e o driver que está sendo utilizado.

1 curtida

Boa noite pessoal.

Hoje de manhã reinstalei o sistema mas esqueci de comentar aqui, a resolução voltou. Agradeço por tentarem me ajudar

3 curtidas