Ajuda com Driver Bluetooth

kubuntu
#1

Boa noite!
Vim aqui para tentar pedir uma breve (acho) ajuda…
Tenho um notebook “Acer Aspire E15” com placa de wireless/Bluetooth interna
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
Tenho um controle Bluetooth “Ipega”, que no cabo funciona corretamente no meu Kubuntu 18.04.
Gostaria de usa-lo sem o cabo, uma vez que esse é minúsculo (menos de 1 metro), mas quando vou ligar o Bluetooth, ele diz que não há Adaptadores Bluetooth instalado, mas como disse anteriormente, a placa é Interna, e esse Notebook não tem botão de liga e desliga da placa (apenas Wifi, mas esse funciona corretamente)


Alguém poderia me ajudar? Seria falta de Driver? se sim, alguém tem o link de algum que possa funcionar?
Na dúvida, vai o LSPCI inteiro abaixo:

00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
03:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

Desde já agradeço a ajuda :slight_smile:

PS. Quando usava o Windows ele funcionava corretamente… Então descarta problemas da placa…

0 Likes

#2

Cara, eu sofri para configurar meu iPega no Xubuntu.
Eu consegui configurar usando o blueman, o bluez não conseguiu parear. Baixe o blueman e faça a conexão manualmente, sem ser automatizada. Antes de mais nada, é necessário ter bluetooth 4.0 para o controle fingindo lá funcionar. O Bluetooth 2.0 não funciona com controles iPega.
Para isso, abra devices (botão direito no blueman > devices), pressione ao mesmo tempo no iPega home + x, após, na janela dos devices clique em search, quando encontrar, clique com o botão direito e siga: parear, confiar, conectar como HID.

Depois disso, se for jogar na steam, abra o Big Picture e configure por ele. Sempre jogue os jogos pela Big Picture, pois ele consegue mapear o controle genérico para xbox360, qual alguns jogos precisam obrigatoriamente ser xbox360 (god save the steam!).

Me adicione no discord qualquer coisa, eu te ajudo com algumas coisas se precisar: drizze#1548

1 Like

#3

Não da pra clicar em nada…

0 Likes

#4

Qual o modelo do seu iPega?

0 Likes

#5

Ipega 9025

Mas não é questão do Controle, uma vez que o Bluetooth meu nem liga ‘-’

0 Likes

#6

Você consegue parear alguma outra coisa que não seja o controle? Celular por exemplo.

0 Likes

#7

nada, da erro “Nenhum adaptador encontrado”
Como se não tivesse placa Bluetooth…
meu note não tem interruptor para ligar e desligar, nem no fn…

0 Likes

#8

De uma olhada nessa solução, parece interessante.

0 Likes

#9

Certo, vou testar e depois eu falo o que deu.
Desculpe a demora, estava trabalhando hoje ^^

PS. Secure Boot no meu note já é desativado, uma vez que instalei o sistema em modo Legacy, pois deu erro no boot quando instalei em UEFI…

apenas pra complementar aqui:

yuuki@yuuki-Aspire-E5-573:~$ lspci -knn | grep Net -A2
03:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036]
(rev 01)
       Subsystem: Lite-On Communications Inc QCA9565 / AR9565 Wireless Network Adapter [11ad:0803]
       Kernel driver in use: ath9k
       Kernel modules: ath9k
yuuki@yuuki-Aspire-E5-573:~$ rfkill list
0: acer-wireless: Wireless LAN
       Soft blocked: no
       Hard blocked: no
1: phy0: Wireless LAN
       Soft blocked: no
       Hard blocked: no

0 Likes

#10

Infelizmente não funcionou, já tentei até atualizar o Kernel para o 5.0.4

yuuki@yuuki-Aspire-E5-573:~$ uname -r
5.0.4-050004-generic

mas não funcionou também =/
o mais engraçado é isso:

yuuki@yuuki-Aspire-E5-573:~$ service bluetooth status
● bluetooth.service - Bluetooth service
  Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
  Active: active (running) since Mon 2019-03-25 08:40:52 -03; 5min ago
    Docs: man:bluetoothd(8)
Main PID: 1118 (bluetoothd)
  Status: “Running”
   Tasks: 1 (limit: 4562)
  CGroup: /system.slice/bluetooth.service
          └─1118 /usr/lib/bluetooth/bluetoothd

mar 25 08:40:52 yuuki-Aspire-E5-573 systemd[1]: Starting Bluetooth service…
mar 25 08:40:52 yuuki-Aspire-E5-573 bluetoothd[1118]: Bluetooth daemon 5.48
mar 25 08:40:52 yuuki-Aspire-E5-573 systemd[1]: Started Bluetooth service.
mar 25 08:40:52 yuuki-Aspire-E5-573 bluetoothd[1118]: Starting SDP server
mar 25 08:40:52 yuuki-Aspire-E5-573 bluetoothd[1118]: Bluetooth management interface 1.14 initialized

Aparentemente o Bluetooth ta rodando, mas quando vou parear escreve “Nenhum adaptador encontrado”

yuuki@yuuki-Aspire-E5-573:~$ hcitool scan
Device is not available: No such device

Mais um comando:

yuuki@yuuki-Aspire-E5-573:~$ bt-device -l
**
ERROR:lib/bluez/adapter.c:165:adapter_get_dbus_object_path: assertion failed: (ADAPTER_IS(self))
Abortado (imagem do núcleo gravada)

0 Likes