Adaptador wifi DWA-131 no Deepin [RESOLVIDO]

Olá a todos.
Estou precisando rodar os comandos abaixo no deepin para meu adaptador funcionar nessa distro. Assim como fiz no mint e no kde neon, depois que executo esses comandos o adaptador começa a piscar e funcionar normalmente. Até colocar esses comandos a internet fica leeeenta e caindo direto.
O problema é que no deepin deu erro logo no primeiro comando.
Segue os comandos e logo depois o erro que aparece no deepin:


A ID é “2001:330d” é importante pois esse número vai determinar o driver correto.

Agora vamos à instalação!

Requisitos:

sudo apt-get install linux-headers-generic build-essential dkms

Comando para clonar o repositório:

git clone https://github.com/pvaret/rtl8192cu-fixes.git

Configurar com o módulo DKMS:

sudo dkms add ./rtl8192cu-fixes

Recompilar e instalar:

sudo dkms install 8192cu/1.11

Atualizar a lista de módulos:

sudo depmod -a

Garantir que o drive nativo do Kernel foi desativado:

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/

Agora é só reiniciar e bom divertimento!

Depois do comando sudo apt-get install linux-headers-generic build-essential dkms aparece o seguinte erro:
O pacote linux-headers-generic não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou está disponível somente a partir de outra fonte

Alguma dica?

Quanto a internet lenta, tem essa dica que é muito boa:

Tópico original:

Quanto a tentativa de instalação, tentei executar daqui e recebi a seguinte mensagem:

Lendo listas de pacotes… Pronto
Construindo árvore de dependências
Lendo informação de estado… Pronto
O pacote linux-headers-generic não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote ‘linux-headers-generic’ não tem candidato para instalação

Acredito que não esteja no repositório Debian, somente no Ubuntu, daí a mensagem acima.

Uma alternativa é baixar o pacote .deb destinado ao Debian: Debian -- Details of package linux-headers-amd64 in stretch

Usando a opcao do iwlwifi.conf parece mais rapida. Vou testar aqui e depois retorno. Obrigado desde ja.

Ainda continua lento, mesmo alterando esse arquivo iwlwifi.conf. Baixei o arquivo *deb do site que você indicou mas aparece a seguinte imagem:
Captura%20de%20Tela_%C3%81rea%20de%20Sele%C3%A7%C3%A3o_20191004180227

teste este

Desculpa minha burrice :pensive:
Baixei o arquivo, descompactei… Tem 3 arquivos executáveis: clean, runwpa, e wlan0dhcp. O que eu faço agora?

Nunca instalei…
Veja o read

O read fala (se é que entendi direito) para executar alguns comandos, sendo o primeiro dele este:
sudo apt-get install linux-headers-generic build-essential dkms
Ou seja, o comando que deu origem a essa postagem.

Sim …

Vai lendo que ele explica como instalar

Certo. Mas se for para executar os comandos volto a estaca 0, ou seja, não passa do primeiro comando como coloquei no inicio desse post.

Vc instalou este

O que te passei é outro arquivo.
Recomendo desinstalar este primeiro

Problema resolvido!!! :smiley: :smiley: :smiley:

Resolvi dar um apt search linux-heards no terminal e apareceu entre outros:
linux-headers-4.15.0-30deepin-generic/lion,now 4.15.0-30deepin.31 amd64 [installed]
Ou seja, já está instalado. Foi só continuar com o restante dos comandos, reiniciar e deu tudo certo, o adaptador fica piscando (como no mint e kde neon) e com a velocidade excelente.

3 Curtidas