Adaptador Wi-fi Deepin

não consigo instalar o adaptador Wi-fi no deepin! Mas no windows 7 funciona normalmente

Poderia nos informar o modelo do seu adaptador?

1 Curtida

USB 2.0 Wireless 802.11NN 900mbs
Print: Imgur: The magic of the Internet

Eu achei esse driver no Git que aparentemente é compatível com esse dispositivo. Mas, se não estou enganado, ele já vem instalado no Ubuntu, no Deepin eu já não sei. De qualquer jeito, tente carregá-lo por esse comando:

sudo modprobe rtl8812au

Se o terminal retornar algo como module not found, é porque ele não ta instalado, então você precisa baixar no Git, compilar e instalar.

Primeiro passo, instalar os as dependências:

sudo apt-get install build-essential dkms make git linux-headers-generic

Segundo passo, baixar o driver:

git clone https://github.com/gnab/rtl8812au.git

Terceiro, compilar:

cd rtl8812au;
make;
sudo make install

Se não ocorreu nenhum erro, então ele esta instalado. Dê um sudo echo 8812au | sudo tee -a /etc/modules pra fazer com que o sistema carregue o driver automaticamente no boot, e pronto. Pra carregar o driver sem precisar reiniciar, use o modprobe: sudo modprobe 8812au.

3 Curtidas

o sudo apt-get install build-essential dkms make git linux-headers-generic não pegou


e o sudo echo 8812au | sudo tee -a /etc/modules tbm acho que não pegou

Aqui ta o print com os arquivos que veio no Cd de instalaçã que não consegui instalar

!

Na segunda imagem faltou um espaço “-a/etc/modules”, o correto é ‘-a /etc/modules’.

1 Curtida

Fiz essa correção e não teve esse erro! Mas reiniciei o computador e tá a mesma coisa.

o passo de compilar o módulo ocorreu sem problema?

cd rtl8812au;
make;
sudo make install

Se você digitar “lsmod | grep wifi” retorna alguma coisa?

Digitei
lsmod | grep wifi e não aconteceu nada
E o módulo de copilar ocorreu tudo normal.

Na terceira imagem onde você mostra as pastas do CD de instalação, na pasta driver tem alguma referência para Linux ?

Você não pode prosseguir com o passo posterior se o anterior não deu certo, isso vai causar problemas. Enfim, descarte aquele primeiro passo, use esse ao invés:

sudo apt install linux-headers-$(uname -r)
sudo apt-get install build-essential dkms make git

Se der certo, prossiga com o segundo passo.

Putz, agora que que o burro aqui viu que a pasta aberta na terceira imagem já é dos arquivos Linux, foi mal…

Siga o que o @anon98068247 descreveu, suba o módulo e veja se funciona, senão veja que dentro do CD, tem um arquivo readme.txt e install.sh, pode ser um caminho, de qualquer maneira você vai ter que compilar algum módulo, essa placa tem dado problema até em Windows (Mais antigos).

1 Curtida